What's NewComing SoonOpeningMiddlegameEndgameSets/BoardsDiscountsDVDsDownloadsApps & eBooks

Service Center

NICBase Online System requirements

To use the NICBase Online consultation database you will need Macromedia Flash Player 6 and a suitable browser.

The Macromedia Flash Player can safely be downloaded and installed from the Macromedia pages (http://www.macromedia.com/shockwave/download/download.cgi?
P1_Prod_Version=ShockwaveFlash&P5_Language=English
). Instructions are given on the Macromedia pages.

If you have any problems installing Macromedia flash please visit the Macromedia support pages at http://www.macromedia.com/support/flashplayer/

If you are using Mozilla 1.0+ or Netscape 6.2+ you will have to make sure that you download Macromedia Flash Player 6 r40 or higher. Before installing the Flash Player on your system, make sure to remove the old 'NPSWF32.DLL' file from your Mozilla/Netscape plugin directory.

In short the following systems are supported:

  • Internet Explorer 4.x or higher on Windows with Macromedia Flash Player 6.x.
  • Java-enabled Netscape 6.2 or higher on Macintosh or Windows with Macromedia Flash Player 6 r40 or higher.
  • If you experience any problems please send your current configuration (platform, browser, flash player) to webmaster@newinchess.com

    Shop topics

    Shop Help
    Security, Account, Order Status, Currencies.

    Delivery Times

    Shipping Costs