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Welcome to HIARCS Chess Explorer

 
Welcome to HIARCS Chess Explorer,  an intuitive  new chess  database,  analysis  and playing  program  for
chess players from beginners to Grandmasters.

HIARCS Chess Explorer is an exciting new chess program for PC and Mac chess players which can run on
both PC Windows and Apple Macintosh OS X computers with native look and feel. It offers an innovative and
intuitive graphical user interface together with the current World Chess Software Champion HIARCS chess
engine. This unique combination is refreshingly easy to use and includes many innovative new features for
chess  preparation,  analysis  and training  for  players  of all  abilities  from  beginner  to  Grandmaster.  It  has
specialised  features  to  help  weaker  chess  players  improve  their  chess  including  special  handicapped
opponents,  a  chess  coach which  can demonstrate  mistakes,  show improvements  and help  you  improve
your chess while maintaining a chess rating for you so you can follow your progress.

There are a great many other excellent features in HIARCS Chess Explorer and we have written this manual
so you can get the most out of our software.

Credits & acknowledgements
HIARCS Chess Explorer is designed and developed by Michal Rudolf and Mark Uniacke.

HIARCS chess engines are designed and developed by Mark Uniacke.

Chess piece set images by Eric de Mund and Bruno Rizzuti based on fonts by Eric Bentzen and Armando
Marroquin.

User Manual written by Mark Uniacke.

Language translations: English by Mark Uniacke, French by Alain Zanchetta, German by Christian
Goralski, Italian by Bruno Rizzuti, Polish by Michal Rudolf, Russian by IM Beglar Jobava and Spanish by
Amador Cuesta.

Many games and annotations provided by www.chess.co.uk. 

Beta testing and feedback by Ole Christensen, Chris Cook , Richard Fowell, Eric Hallsworth, Jonathan
Naud, Matt Read, Bruno Rizzuti and Harvey Williamson and a number of other testers who prefer to remain
private.

Thank you to all those people who helped make HIARCS Chess Explorer a better product.
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We also thank Eugene Nalimov and Andrew Kadatch for their kind permission to use their access code
(copyright (c) Eugene Nalimov) and decompression code (copyright (c) Andrew Kadatch) for Nalimov
tablebases in HIARCS chess engines.

System requirements
HIARCS Chess Explorer has the following system requirements:

PC Windows
Requires: PC MS Windows™ XP, Vista, Windows 7 (all versions 32 & 64 bit)
Computer: Any Intel or AMD with at least 512Mb RAM running one of the OSs above

Languages supported in the GUI are English (UK), English (US), French, German, Italian, Polish, Russian
and Spanish.

Included items
HIARCS Chess Explorer includes the following main components:

· HIARCS  Chess Explorer  Graphical  User  Interface  (GUI)  -  this  is  the  presentation  you  see  and
interact with.

· HIARCS chess engine(s) - this is the electronic chess brain which analyses and plays chess. HIARCS
Chess Explorer supports engines  which  comply  with  the  Universal  Chess  Interface  specification.  The
HIARCS chess engines included in the package are UCI compatible:

o Deep HIARCS 14 WCSC (available with the Deep HIARCS Chess Explorer product)
o HIARCS 14 WCSC

· Opening  books -  these are  collections  of positions,  moves  and statistics  which  help  show you the
chess openings, play chess openings and classify and name openings played. These electronic books
are used by HIARCS Chess Explorer to present the information within  them.  They  cannot  be  read by
other software.

· Chess databases -  these are  collections  of players,  games  and commented games  which  you  can
load, view, modify, play through etc, etc. The following databases are included:

o TopGames  -  this  is  a  database  of  games  between  the  world's  strongest  chess  players,
generally of last 20 years.

o AnnotatedGames - this is a database of games  annotated  by  strong chess  players  including
International Masters and Grandmasters.

o FischerSpassky  -  this  database  contains  all  the  games  played  between  these  great  rival
players.

o KasparovKarpov -  this  database  contains  all  the  games  played  between  these  great  rival
players.

o Tactics-WAC300 - this database contains 300 tactical puzzles, you can see the solution in the
game header extra tags dialog.

Please note you can add other  UCI chess  engines  including  third  party  UCI chess  engines  into  HIARCS
Chess Explorer. You can also use HIARCS chess engines in other chess GUIs which support  UCI engines.
We advise activation of our engines in HIARCS Chess Explorer as we have found many other chess  GUIs
are not 100% compatible with the UCI specification for activating/registering engines.

Installation on PC Windows
When you purchase HIARCS Chess Explorer you will be sent an email with a download link where you can
download the HIARCS Chess Explorer installer.  To download the HIARCS Chess  Explorer  Installer  please
click on the link you were sent immediately after purchase. On Windows XP you will then see a dialog like
this:
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If you select Run the HIARCS Chess Explorer Installer will be downloaded and then executed. Alternatively
you can save it  locally to your computer and run it  later.  If you do save the  installer  instead of running  it,
then please make a  note  of where  you saved it  so  you  can  run  it  later  Simply  double  click  the  saved
setupHIARCSChessExplorer file to start the installer.

On Vista,  Windows 7 after downloading the installer the dialog  will  look  like  this.  Please note  the  verified
publisher is  "Applied  Computer  Concepts  Ltd.",  do  not  trust  the  download if  it  is  not  signed by  "Applied
Computer Concepts Ltd."

Once you run the installer you will see this dialog:
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Before you can install HIARCS Chess Explorer you will need to accept the terms of the End User License
Agreement.

In the next dialog you will have the choice to create a desktop icon which will appear on your desktop and
make launching HIARCS Chess Explorer easier.

You will then be given a dialog which simply asks you to click the Install button to  install  HIARCS  Chess
Explorer. Click this button and installation will begin, you will see the installation progress:
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Once the installer is  complete you will get the following dialog confirming successful installation and giving
you the option to launch HIARCS Chess Explorer.

 HIARCS Chess Explorer is now installed on your computer.

Installation Folders
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When HIARCS Chess Explorer is installed it  creates  a  number  of folders  for  the  Application  itself,  chess
engines and data files including databases. This section explains where the files are installed.

Installation folders on PC Windows
On PC Windows the HIARCS Chess Explorer installer creates the following folders:

Application Folders
The application and engines are installed in the \Program Files\HIARCS Chess folder.  Inside this folder you
will find the following folders installed:

· HIARCS Chess Explorer - this folder contains all the files and folders of the Graphical User Interface

· Deep HIARCS 14 WCSC -  this  folder  contains  all  the  files  of the  multiprocessor  HIARCS  14 WCSC
version

· HIARCS 14 WCSC - this folder contains all the files of the single processor HIARCS 14 WCSC version

Please note  on  Windows  64 bit  systems  the  "\Program  Files  (x86)"  folder  is  used instead of  "\Program
Files"

Data Folders
The HIARCS Chess Explorer user files are installed  in  your  documents  folder.  On Windows  XP  this  is  in
your "Your Documents" folder, on Windows Vista and later it  is  in your "Documents" folder.  In this location
you will find the "HIARCS Chess" folder is installed and contains the following sub folders:

· Books - this folder contains the books HIARCS uses, book subscribers can add books issued as part  of
the Book Subscription to this folder and HIARCS 14 engines will automatically use the latest book.

· Databases  -  this  folder  contains  the  packaged  databases  which  are  included  with  HIARCS  Chess
Explorer

· Documentation - this folder contains the documentation and help files for the product

· Engine Data - this folder contains the engine data folders, HIARCS 14 will save its learn files here

· Explorer - this folder contains files specific to the HIARCS Chess Explorer GUI.

Activation
When HIARCS Chess Explorer first runs you will be asked to enter your license key.
Your personal license key was emailed to you immediately after you purchased HIARCS Chess Explorer.
Enter the license name and code into the Registration dialog to activate the product:

You can copy (Ctrl+C) and paste (Ctrl+V) the license name and code into each field.

Once you have entered the license name and code,  click  the  Register  button  to  activate  HIARCS  Chess
Explorer.
After  a  short  delay  you  will  then  get  confirmation  that  HIARCS  Chess  Explorer  has  been  successfully
registered/activated:
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If there is something wrong with the entered license name and code you will be given the following dialog:

You should then click OK and enter the correct license name and code into the Registration dialog.

Updating your license

In the vast majority of cases you will not  have to  update  your  license however  when you have purchased
HIARCS Chess Explorer and wish to upgrade to the Deep HIARCS Chess Explorer version you will be sent
a  new license key  and you can update  the  product  to  the  Deep functionality  by  entering  the  license as
follows: 

1. Open the About HIARCS Chess Explorer dialog by choosing the Help->About HIARCS Chess Explorer
menu item.

2. Click on the Update license button to update your license.

3. You will then be able to enter your new license details to complete the update.
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Concepts

Chess game databases
Collections  of chess  games  are  stored in  files  called  PGN  databases.  PGN  stands  for  Portable  Game
Notation, it  is  a standard way  to  store  chess  games  independent  of  the  hardware  and software  program/
application which produced it. HIARCS Chess Explorer reads and writes chess databases in PGN format.  It
does not support any non standard format of database.

Chess Explorer paradigm
In the context of  a  chess  game HIARCS  Chess  Explorer  uses  a  different  approach to  most  other  chess
software. Most chess software focuses just on the current game and the database is a secondary concern
mainly used as a repository to store and retrieve games.  We believe this approach is not as powerful as the
database centric paradigm that HIARCS Chess Explorer uses. We will explore this in more detail below.

HIARCS  Chess  Explorer  uses  a  database  first  approach,  this  means  you  open  the  database  you  are
interested in first and then you can view, modify, delete or add games to it. 

Secondly HIARCS Chess Explorer is a multi-database program, that means you can open, view, manipulate
and analyse games from multiple databases simultaneously.

These two facets of database first and multi-database  capabilities enable much more powerful solutions
than a single game, single database approach more normally used.

Using  a  database first  and multi-database approach gives  some  genuine  advantages  over  the  traditional
approach:

· Choosing a database first  sets  the  context  for  the  game and leverages  other  related  information  in  a
database to make the entry, analysis or viewing of a game more informative. 

· The game can draw on information from the other games already in the database in a number of ways:
o Compare in real-time the current game to other games played in the database
o Show  what  other  players  have  played  before  in  the  same  position  and  how  they  faired

statistically
o Enable real-time access to other games which have encountered the same position to see how

those games progressed.

· Manage your games better by using databases not just as a repository to store games but as a way of
organising your games and analysis,  for example you can store your games in multiple  databases  for
different purposes:

o maintain a database of your own games to get an automatic opening repertoire tree generated
for you. 

o prepare  for  an  opponent  by  generating  a  database  of  their  games  and  having  their  opening
repertoire tree presented automatically

o Analyse games  of your  favourite  player  and get  additional  information  about  the  player,  their
moves, openings and performances

· Manage multiple databases at the same time to perform distinct operations simultaneously:
o Have an analysis database open where an engine can be analysing your game
o Simultaneously you can be examining other databases of games and working independently of

the analysis being done for you in another database
o Manage game collections more effectively by having access to multiple sources
o Transfer games between databases more quickly and smoothly. 

Don't panic if that sounds complex, it really is not and we have example usage in the Getting started section
to show how different tasks can be achieved simply within HIARCS Chess Explorer.

If you are a novice user do not worry as HIARCS Chess Explorer can be used to manipulate just  a  single
game and database at a time if you prefer to keep things very simple.

One of the  key  aims  of HIARCS  Chess  Explorer  is  to  simplify  the  user  experience and provide  a  set  of
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powerful tools for the novice and accomplished player alike, to analyse and play chess.

Database tabs

Each database in HIARCS Chess Explorer is opened within a tab.

This  means  you  can  have  multiple  databases  open  simultaneously  without  having  to  manage  lots  of
windows.

You  can  move  tabs  around  by  simply  selecting  a  tab  and  dragging  and  dropping  the  tab  into  a  new
placement,  for  example  you  can  drag  the  notepad-db  tab  and  place  it  between  the  MyGames  and
TopGames database tabs.

To work on a database simply click on the tab and the database and its display panes will be accessible.

In the above example we have 5 tabs open:
1. MyGames database where I am entering a game
2. The packaged TopGames database where I am examining some games
3. The packaged AnnotatedGames database where I am playing though an annotated game.
4. Playing game tab where I am playing a game against the computer
5. Notepad-db where I have HIARCS analysing a game

As you will find out HIARCS Chess Explorer makes it  simple to have multiple databases open at the same
time and this  ease  and  flexibility  allows  a  different  approach  to  analysing  and  working  with  databases
compared to single game/database programs.

You can close a database at any time by clicking X next to the name of the database tab or by selecting
the File->Close menu item which will close the database in the current selected active tab.

Please note when opening very large databases it  can take some time to load all the games and build the
required  views  of  the  data.  However  once  the  database  is  loaded  even  complex  position  searches  are
performed almost instantly. Equally when you exit a database tab containing a very large database it  takes
time to save if changes have been made to that database.

Databases and Filters

In HIARCS Chess Explorer there are up to 3 groups of games which some operations can be applied to:

· Database - all the games in the database

· Filter - only the games in the current search filter

· Current game

Some functions operate on all three groups, while other's handle only the current game or some combination
of game and filter.

When you first open a database the current filter is set to the whole database. When you search for games
the resulting set of games becomes the new filter.  In numeric terms the size of the  filter  is  shown on the
status bar in the bottom right hand corner of the window, for example:

This shows  you that  the  Game Explorer  is  showing 287 out  of  34191 games.  The current  filter  contains
those 287 games.

There  many  ways  to  search  for  games  that  set  the  games  filter  you can read more  about  these  in  the
Finding games section.
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Although the filter is normally set as a result of a search you can add to the existing filter using the Header
search.

Elo ratings

Chess players are given a chess rating to gauge how strong they are at chess. The standard rating system
used in chess is called Elo ratings named after Arpad Elo. A related system is used in tennis,  football and
many other sports.

Elo  ratings  are  based on the  results  of  games  and ratings  of opponents  played.  The  Elo  rating  system
ranges from 1000 Elo (a complete novice) to 2800 Elo and beyond for the strongest players of all time.

Were a player A to score two points for every one point of player B, then player A would be expected from
this performance to have an Elo rating about 120 Elo points more than player B. As you can see there is a
great difference in chess strength as you go up the ratings.

The ratings can be split into the following broad classes:

Class of Player Rating Range

World Champion 2800+ Elo

World Championship contender 2700-2800 Elo

Super Grandmaster 2600-2700 Elo

Grandmaster 2500-2600 Elo

International Master 2400-2500 Elo

Master 2200-2400 Elo

Expert 2000-2200 Elo

Class A - Strong club player 1800-2000 Elo

Class B - Club team player 1600-1800 Elo

Class C - Club player 1400-1600 Elo

Class D - Hobby player 1200-1400 Elo

Class E - Beginner/Novice 1000-1200 Elo

Class F - Complete beginner 750-1000 Elo

HIARCS Chess Explorer allows you to set any of these strengths in the play game mode.

ECO opening naming

Chess Informant Inc developed the Encyclopaedia of Chess Openings which is a system of classification for
chess  openings  into  5  main  groups  of openings,  each of these groups  has  a  100 different  categories  of
openings. 

HIARCS  Chess  Explorer  can classify  openings  into  their  ECO codes  and further  more  name  the  actual
openings. You can also access openings by name to practice those openings and also the Player Explorer
can classify favourite openings of players and databases.

For reference here is an overview of the ECO codes and opening names:  

· A00-A99: Flank openings
o A01 Nimzowitsch-Larsen Attack
o A02-A03 Bird's Opening
o A04-A09 Reti Opening
o A10-A39 English opening
o A40-42 Queen's Pawn Opening
o A43 Benoni/Old Benoni
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o A45-A50 Queen's Pawn 1.d4 Nf6
o A51-A52 Budapest Gambit
o A53-A55 Old Indian Defence
o A56 Czech Benoni
o A57-A59 Benko/Volga Gambit
o A60-A79 Modern Benoni
o A80-A99 Dutch Defence

· B00-B99 Semi-open games (not including the French defence)
o B00 King's Pawn Opening
o B01 Scandinavian Defence
o B02-B05 Alekhine Defence
o B06 Modern/Robatsch Defence
o B07-B09 Pirc Defence
o B10-B19 Caro-Kann Defence
o B20-B99 Sicilian Defence

· C00-C99 Open games (including the French defence)
o C00-C19 French Defence
o C20 King's Pawn Game
o C21 Danish Gambit
o C22 Center Game
o C23-C24 Bishop's Opening
o C25-C29 Vienna Game
o C30-C32 King's Gambit Declined
o C33-C39 King's Gambit Accepted
o C40 Latvian Gambit
o C41 Philidor Defence
o C42-C43 Petroff Defence, 3.Nxe5
o C44 Ponziani Opening
o C45 Scotch Game
o C46 Three Knights' Game
o C47-C49 Four Knights' Game
o C50 Italian Game - Giuoco Pianissimo
o C51-C52 Evans' Gambit
o C53-C54 Giuoco Piano, 4.c3
o C55-C59 Two Knights' Defence
o C60-C99 Ruy Lopez

· D00-D99 Closed and semi-closed games
o D00-D03 Queen's Pawn Game
o D04-D05 Colle System
o D06-D09 Queen's Gambit, Irregular
o D10-D19 Slav Defence
o D20-D29 Queen's Gambit Accepted
o D30 Queen's Gambit Declined: Slav
o D31 Queen's Gambit Declined: Semi-Slav
o D32-D34 Queen's Gambit Declined: Tarrasch Defence
o D35-D42 Queen's Gambit Declined
o D43-D49 Queen's Gambit Declined: Semi-Slav main line
o D50-D69 Queen's Gambit Declined: Classical
o D70-D99 Grünfeld Defence

· E00-E99: Indian defences 
o E00 Indian Defences
o E01-E09 Catalan Opening
o E10 Blumenfeld Gambit
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o E11 Bogo-Indian Defence
o E12-E19 Queen's Indian Defence
o E20-E59 Nimzo-Indian Defence
o E60-E99 King's Indian Defence
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Getting started

The following subsections explain how to perform many of the common operations typical customers want
to use. Detailed explanations about the user interface can be found in the User Interface section.

Launch HIARCS Chess Explorer
Once HIARCS Chess Explorer is installed you will have three possible ways of starting it:
1. Use the desktop launch icon (if you chose to install it) - clicking the icon will launch the application 
2. On the  Start  menu you will  find  the  HIARCS  Chess->HIARCS  Chess  Explorer  menu item  which  will

launch the application.
3. If  you  have  any  PGN  database  files,  HIARCS  Chess  Explorer  is  set  on  installation  as  the  default

application  to  open these files.  Therefore  you can double  click  PGN  files  to  launch  HIARCS  Chess
Explorer with that PGN database loaded.

Please note  some applications  may  change the  default  application  to  open  your  PGN  database  files.  If
HIARCS Chess Explorer is not the default  application for the PGN file type you can set it  as  explained in
the Open PGNs with section.

Open PGNs with

On installation  HIARCS  Chess  Explorer  is  set  as  the  default  application  to  open PGN  database  files.  If
HIARCS Chess Explorer is not the default application for the PGN file type you can set it by right clicking on
a PGN file in Windows Explorer and selecting properties when you will see the following dialog:

You will see the line beginning "Opens with",  if that does not  say  HIARCS  Chess  Explorer  you can click
Change... and change the default application to open your PGN databases.
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Accessing help
HIARCS Chess Explorer supports many levels of help:

· tool tip help - as you pass the mouse pointer over the icons a short textual description of the icon will be
displayed in a tool tip which will  pop up and in  the  status  area in  the  bottom  left  hand corner  of  the
screen.

· context sensitive help - this gives help appropriate to the window or dialog you are using.

· a full detailed manual with contents, search and hyper-linked navigation

Help menu

On most dialogs within the GUI you can access context sensitive help by pressing F1 or choosing the Help-
>Context help. This will then bring up a window which will display the help for the window or dialog in focus.

Open database of games

To open a  PGN  database  you  can  click  the  open  database   toolbar  icon  or  choose  the  File-

>Open... menu item to locate and open a PGN database. Please see the Open database section for details
on how to locate a PGN database file to open.

If your database is in a non standard format,  for example, CBF, CBH, you should first  convert  the database
to PGN format using the software which produced the non standard format.

Making moves
To move a piece simply move the mouse pointer over the square of the piece you wish move, click the left
mouse button to select the  piece.  You can then hold  the  mouse button  down and drag the  piece to  the
destination square and let go to make the move.

When Guess move (Preferences->Board tab) is off you can select the source square with a click/release of
the left mouse button and then select the destination square. However we believe most people will prefer to
use the much faster Guess move approach which is on by default.

You can read about more advanced move entry capabilities in the Game Board section.

Guess move
If you have guess move enabled you will notice as you move the mouse over a square of a piece you can
move, the best expected destination square is highlighted.  You can select that recommended move simply
by clicking the mouse button and releasing it.
Alternatively with the mouse pointer over a piece, if you then click the right mouse button guess move will
highlight what it thinks is the next best destination square for the piece highlighted. Repeatedly pressing the
right mouse button will cycle through the moves in order of quality.  Click and release the left  mouse button
to select the currently highlighted guess move.

Also if you move the mouse pointer over a square which a piece can move to you will see the best source
square for that move highlighted. If you want to select  that  move simply  click  and release the  left  mouse
button.
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Playing games against the computer
HIARCS Chess Explorer has a special mode for playing games against the computer. 

You can access this mode by clicking the Play game  toolbar icon or from the Play->New game...

menu item. 
To read more about how to start  a game against the computer and configure the type of game you wish to
play please read the Play game section.

Play Realism
HIARCS chess engines use new play realism capabilities which give a much more realistic human like feel
to the play of the weaker set Elo opponents in the HIARCS chess engine. In particular it tries to produce the
same sorts  of  mistakes  and common moves  that  weaker  players  are  prone to.  This  enables  you to  get
genuinely  useful  practice  against  our  handicap  opponents  as  they  will  challenge  you  very  much  like  a
human player  of  that  strength  while  making  similar  mistakes  to  players  of  that  strength.  In  addition  it
matches the opening book moves to the playing strength and even forgets its book moves or mixes up move
orders to simulate real play.

View previous games played against computer
HIARCS Chess Explorer saves all the games you play against the computer unless you explicitly  tell it  to
abandon  a  game  and  not  save  it.  You  can  access  all  the  games  you  have  played  in  the  special
PlayedGames database simply by selecting the Play->View played games menu item:

This will automatically open a new database tab for  the  PlayedGames  PGN database and display  all  the
games played in the Games Explorer pane at the bottom of the window.

Creating a database
A  PGN database represents  a  collection  of games.  You can use  a  PGN  database  to  organise  games.
Please see the section on creating a PGN database for details.

It is beneficial to organise games into databases so you can utilise the powerful features of HIARCS Chess
Explorer.

Managing my games
To manage your  games  we recommend you maintain  a  PGN database of your  games  -  don't  store  the
games of other players in this database. This will enable you to use the  Opening  Explorer  feature  on  this
database to  give  you a  live  opening  repertoire  tree  of your  games.  This  is  a  powerful  way  to  view  your
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games, the positions and moves you have played.

If you have been using another  chess  software  application  we recommend you save your  games  in  PGN
format - that is the Portable Game Notation that allows you to transfer your games in a portable way similar
to  what  PDF  documents  are  to  documents.  You  can  open  the  PGN  of  your  games  in  HIARCS  Chess
Explorer  or  copy  and paste  all  the  games  into  a  new PGN database within  HIARCS  Chess  Explorer  by
using the copy and paste games function.

If you don't already have a database of your games in PGN format you can set this up as follows:
1) Create a new database and name it - for example MyGames
2) If you have the game entered in a different chess software application you can copy and paste it  into the
MyGames database tab.
3) Enter your games into the Game Notation and save each game into the MyGames database. As you do
this you will see the Opening Explorer is automatically building an opening repertoire tree from the games.

You  can  then  use  Analysis  Explorer  to  analyse  your  games  and  update  your  games  database  with
annotations and variations as appropriate.

You can also  store  your  games  in  other  databases  as  appropriate.  HIARCS  Chess  Explorer  can  open
multiple databases simultaneously so you can easily handle more than one databases at the same time.

Entering and annotating games
To enter a game first decide on the database context for this game. This is important so you put the game
in the correct game collection. You can of course copy and paste games to different databases but it makes
sense to choose the PGN database appropriate for the game you wish to enter.

With  the  database  open  it  appears  in  HIARCS  Chess  Explorer  in  its  own  tab.  With  the  database  tab
selected you can choose the Game->New menu item and the Game Notation will be cleared ready for entry
of a new game.

You can enter moves and add comments, move symbols,  evaluation symbols or other symbols at any time
using the move context menu.

Analysing games
You can have any compatible UCI engine analyse a game. With the game loaded in the Game Notation you
can access analyse game in one of two ways:

· choose the Game->Analyse game... menu item and the Analysis Explorer will open (if not already open)
and select the last engine used and open the Analyse Game dialog for you to configure the analysis.

· Alternatively  with  the  Analysis  Explorer  pane  open  you  can  select  the  engine  you  wish  to  use  to

analyse the game and then click the analyse game icon  next to the engine name. 

Please see the Analyse Game dialog section for details on configuring game analysis.

Learning to play openings
You can practice  playing  openings  using  the  non  standard  starting  position  element  of  the  Play  game
dialog:
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This allows you to select from well over a hundred named openings both to learn different opening systems
and get practice in those positions.

Please see the Play game section for further details on other elements of this dialog.

Opening preparation
One the advanced features of HIARCS Chess Explorer is its ability to allow players of all strengths to
prepare their openings and also prepare for opponents. As an example we will briefly take a hypothetical
look at how you could prepare an opening to play as Black against ex World Chess Champion Garry
Kasparov.

Find games of opponent
We first open the "TopGames" database which is packaged with HIARCS Chess Explorer.
In the Game Explorer dialog we can use the Quick search field to find all games played by Garry Kasparov
with the White pieces. We simply enter "Kasparov-" and press return (or click Find) and all Kasparov's
white games will appear in the Game Explorer pane. Please note you can easily make advanced searching
combinations, see the Quick search section for details.
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Using Opening Explorer

We can now open the Opening Explorer pane  and set the Source to be the current Filter. Opening

Explorer will now display all the moves played in Kasparov's games in the current position together with the
statistics for those moves. With the source set to the Filter, Opening Explorer will only show moves and
statistics from the games within the current Filter. The current filter and games listed in the Game Explorer
pane can be redefined to list only games which contain the current position simply by clicking the Show
games button at any time.
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We can see based on this data that Garry Kasparov is most likely to play 1.e4. 

You will also notice I started a new game (Game->New menu) so I can explore variations played in Garry's
games. You can select moves in the Opening Explorer pane to follow different paths until you find something
interesting. You can also enter moves and variations and explorer positions as much as you like.

We will assume Garry will play 1.e4 and so we will follow his most common (likely) moves in the Opening
Explorer (Source: Filter).... we then reach the Sicilian Nadjorf line 1.e4 c5 2.Nf3 d6 3.d4 cxd4 4.Nxd4 Nf6
5.Nc3 a6 6.Be3

We now find Opening Explorer is showing us a difficult choice - there are a number of choices for Black and
they all appear to have bad Scores at least against Garry Kasparov! Remember the Score is always the
percentage that White achieves in these lines. 

In order to help choose the best move in this position we seek information from other sources. First we
select the local opening book to get an idea of the popular GM moves in this position:
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Now we can compare that with the wider and deeper Online book: GM+

We can see from this information that 6..e5 is the recommended move from GM practice, so we will follow
this move in the game notation, the Opening Explorer will continue to show us the moves and statistics from
Kasparov filter. There are two games from the Kasparov filter which follow this 6...e5 line. So we now follow
the line 6...e5 7.Nb3 Be6 8.f3 Nbd7 9.g4 h6 10. Qd2 which is well established theory until we find the two
games played diverge. To see these games click the Show Games button and Game Explorer will set a
refined Filter to these two games and display the two Kasparov games which contain this position: 
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Now while the statistics do not look good for Black here, there are simply too few games to form any real
opinion on these moves. So we consult the Online GM+ book:

This gives us some confidence that it may be worth pursuing the 10...b5 or 10...Be7 line. So we select the
game containing the popular 10...b5 and following that game using the book sources to see what
improvement we could make in this line we follow the game some more.



26 / 92

Finally we reach the position after 11.O-O-O Nb6 12.Qf2 Nfd7 13.Kb1 where the local opening book does
not even consider the move 13...g6 played in the game and offers two alternative moves. So we should
check this out as the local opening book contains established GM theory so we can conclude that 13...g6
has only been played once in GM practice and that was in this game!

Let's consult the Online GM+ book for more information and possible moves:

Indeed the Online GM+ book indicates 13...g6?! is dubious. We can also see that the Online GM+ book is
recommending the move 13...Rc8 and the statistics look reasonable for this move for Black. We could now
prepare this line further but this is beyond the scope of this manual. You can see how the multiple sources
of information can be used to help prepare your openings.

Finally for HIARCS book subscribers you can access the World's strongest opening book directly from
within HIARCS Chess Explorer. Once you have entered your book license in the Preferences->Advanced
tab. Select the Source: Tournament book and you will see the moves from the HIARCS Tournament book
in Opening Explorer:

http://www.hiarcs.com/chess-opening-book.htm
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Here we can see the HIARCS Tournament book offers the interesting move 13...Nc4!

The multiple sources of the Opening Explorer can be used in many ways to help you analyse games,
positions and openings. I hope this section has helped give you some ideas on how it can be used.

Finding games
There are many ways in HIARCS Chess Explorer to find games in an open database:

· Select the Search header  toolbar icon or Search->Header menu item to access the Search

header dialog to search the database for games matching game header criteria, e.g. players, event,
rating, dates etc, etc. Please see the Search header section for more details.

· Open the Game Explorer pane and use the Quick search field for fast searching.

· Open the Opening Explorer and use the Source: Database and Show games button to show all games
matching the current poition

· Open the Player Explorer and find games of a particular player 

· Use the Search->Position menu item to open the Search for position dialog to find the games containing
a position you are interested in.

When you first open a database the current filter is set to the whole database. When you search for games
the result is normally a subset of the games and this subset is the current game filter.

Every time you search for games it creates a new filter of games. Using the Header search it is possible to
add to the current filter of games.

Finding players
You can find a player in the open database as follows:

· If you have a game open in the Game Notation pane with the player you are interested in you can click
the player name to access the Player information with games, performances and favourite openings etc.

· Open the Player Explorer dialog and search for the player you are interested in.

Configuring the program
You can configure HIARCS Explorer using  the  Preferences  dialog.  This  can be accessed by  clicking  the

preferences toolbar icon or from the Edit->Preferences menu item.

Add a new chess engine
You can add additional UCI chess engines to HIARCS Chess Explorer using the Preferences->Engine tab
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Copy and paste game or positions
You  can  copy  and  paste  Games  and  Positions  between  chess  software  using  the  Copy  and  Paste
submenus of the Edit menu.

To copy a game in the current tab, use the Edit->Copy->Game menu item, the game is then copied to the
clipboard. If you are copying from another chess software application please consult the manual/help for that
application on how to copy a game in PGN format.

To paste a game from the clipboard, use the Edit->Paste->Game menu item.

A position can be copied  and pasted in  the  same way  using  the  Edit->Copy->Position  and Edit->Paste-
>Position menu items. Positions are copied in FEN format.

For more details please see the Edit menu section.

Merge game
One of the unique and powerful features of HIARCS Chess Explorer is the Merge game feature.

You can access Merge game from the Edit->Paste->Merge with current game menu item

This feature allows you to paste a game from the clipboard into the current game, merging the two games
together.

This enables  you to  analyse  a  game in  multiple  database contexts  or  even in  other  chess  software  and
merge your work at the end into one single game in HIARCS Chess Explorer.  This allows you to collate all
your analysis from multiple sources into one game within the Game Notation. This is also useful if someone
else does some analysis for you and sends you the game you can easily merge the game with  your  own
work.

Copy filter and database games
HIARCS Chess Explorer allows you to copy all the games in the current filter or even the whole database of
games to another database in a very simple manner.

First ensure you open the database you want to copy the games from and the database you wish to copy
the games to. Go into the tab of the database you wish to copy from. If you want to set a filter of games to
copy you can do that in the normal way using the search and filter capabilities.

To copy and paste the games in one operation select the Edit->Copy->Games...  menu item  and you can
then copy either a single game, the current filter of games or the whole database into another database in
one operation.

Printing games
HIARCS  Chess  Explorer  can print  single  or  multiple  games  including  commentary,  variations  and  chess
diagrams.

File->Print submenu

Any loaded game can be printed simply by selecting the File->Print->Current game menu item. The game
can be printed directly to a printer or to a file.

You can set diagrams at any point in the game notation and the diagrams will be printed at that point  in the
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game print out. Diagrams will include algebraic coordinates if you are using them in the on screen display.

You can even print multiple games using the File->Print->Games from filter menu item. You should use this
option with caution since it can print many games. You will be warned if you try to print  20 or more games
as this will use a lot of paper.

Setting a language
HIARCS  Chess  Explorer  will  use  the  default  language  of  your  operating  system.  If  you  want  to  use  a
different language you can choose the language in the Preferences->Advanced tab. There you can set  the
language to English (UK), English (US), French, German, Italian, Polish, Russian and Spanish.
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User Interface

The following sections explain the HIARCS Chess Explorer User Interface, its Main window, display panes,
menus, icons and dialogs. They form the basis of the context sensitive help.

Main Window

The main windows of HIARCS Chess Explorer is split into the following parts:

· Title of window: Current database name - HIARCS Chess Explorer

· Menus at the top of the window

· Shortcut icons for accessing common functions

· tabs one per database, here we have only one database open called AnnotatedGames.

· Game Board which shows the current position of the game being examined.

· Game Notation shows the current loaded game including comments, variations and symbols etc.

·  Game Explorer shows the list of games in the database and provides functions to explore the

database  for  games.  The  Game  Explorer  pane  is  optional  and  its  presence  is  toggled  using  the
Database Info icon.

·  Opening Explorer provides multi-source real-time access to opening moves and statistics.The
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Opening Explorer pane is optional and its presence is toggled using the Book icon.

·  Analysis  Explorer  provides  access  to  engine  analysis  with  statistics,  history  and  game

analysis.The Analysis Explorer pane is optional and its presence is toggled using the Computer icon. 

·  Play game mode provides the ability to play chess against the computer. 

The height and width of the Game Notation, Opening Explorer and Analysis Explorer panes can be adjusted.
The height of the Game Explorer pane can also be adjusted. The chess board will automatically adjust size
to fit.

Game Board

The Game board displays the current chess position of the game in the Game Notation window. The current
side to play is shown to the right of the board with a white square for white to play and a black square for
black  to  play,  in  our  example  white  is  to  play.  The  algebraic  coordinates  around  the  chess  board  are
optional,  other attributes of the board including  the  board  textures  and piece sets  can also  be  set  in  the
Preferences->Board tab.
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Move entry

To move a piece simply move the mouse pointer over the square of the piece you wish move, click the left
mouse button down to select the piece. You can then hold the mouse button down and drag the piece to the
destination square and let go to make the move.

If you hold down the Shift key while entering a move it will be added as the new main line with the previous
main line becoming a variation.

If you hold down the Ctrl key while entering a move it will be added as the new main line and remove the old
line.

Please note that you can use Undo/Redo command to undo mistakes, so even if you have added, modified
or removed many items in the game notation you can always reverse these changes.

When Guess move (Preferences->Board tab) is off you can select the source square with a click/release of
the left mouse button and then select the destination square. However we believe most people will prefer to
use the much faster Guess move approach which is on by default.

Guess moves

With the Guess move feature enabled, when the cursor goes over a piece  the  piece will  highlight  and the
suggested best destination square for the piece will be highlighted. You can select the guess move simply
by clicking the left mouse button and releasing it.

With the mouse pointer over a piece, if you then click the right mouse button and Guess move will highlight
what it  thinks is the next best destination  square  for  the  piece highlighted.  Repeatedly  pressing  the  right
mouse button will cycle through the moves in order of quality. 

When placing the cursor over a square on the board Guess move will highlight the suggested best move to
that square.Again clicking the right mouse button will show the next best move to  the  destination  square,
with each click cycling through the moves in order of quality.

You can select the currently highlighted guess move at any time simply by clicking the left  mouse button
and releasing it.

When you click the left  mouse button on a piece to move it,  Guess move will colour  code the  destination
square highlight to indicate move quality. Here are the default colours:

These colours are used with dark/light intensity to show move quality.  These colours are configurable in the
Preferences->Board tab

Resizing

The chess board will  automatically  resize  in  response to  the  size  of the  overall  HIARCS  Chess  Explorer
window and any panes and their widths used within it.

The Game board and pieces can support  up to a massive 2,400 x 2,400 pixel resolution without losing any
quality.
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Game Notation

The Game Notation pane displays the game header information, moves, comments, variations and symbols
for the current game.

Game Header Information
At the top of the game notation we have:

· White  and Black  player  names  and Elo  ratings  (if  available)  and  the  game  result.  Please  note  the
players names in blue are hyper-linked so you can simply click the player to open the Player Explorer
to view the games, performances and favourite openings of the player in the Information tab.

· The event and site where the game was played and the round and date on which the game was played

· The ECO code and opening name

Game Notation
Below the game header information the actual game is displayed. The game notation can have the following
information:

· The main line of the game (e.g. the moves played in the game) is shown in bold text

· Move variations (these can be nested) are shown in blue

· Comments are shown in green as are diagram designations (see move 13.dxe5)

· Move, evaluation and other symbols are shown in red (see respectively 14. Bh3!? 10. Qc8=, 12.Rac1N
etc)

· The current move is highlighted (see 13.dxe5) and the position after the highlighted move is displayed
on the Game Board.

Navigating the game notation
There are many way to navigate the game in the game notation:

· Use the mouse left click to go directly to any move or variation, the position will then be shown on the
Game Board.

· You can navigate to the beginning of the game, previous move, next move or end of game by using the
move navigation icons:
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· The play  navigation  icon above gives  the  ability  to  start  replaying  the  game  moves  from  the  current
position. The pause icon pauses the replay.

· The keyboard can be used to navigate the game, if you use the left  or right arrow keys they will move
backwards  or  forwards  through  the  current  line  of  play.  The  arrow  key  navigation  will  not  present
annoying variation dialogs or enter sub-variations.

· To be offered the move variation choices at each move use the Ctrl+right arrow.  If there  is  choice  of
moves at any point in the game notation you will be given a Select move dialog so you can choose the
continuation. 

· The Ctrl+left arrow  will jump back to the previous  higher  variation  which  is  just  before  the  point  this
variation branch was entered.

· The down arrow jumps forward 5 moves on the current line, while up arrow will jump back 5 moves on
the current line.

Undo/Redo
You can perform unlimited undo and redo operations performed in the Game Notation on the current game
since it was loaded. See the Undo/Redo section for details.

Move context menu
You can right click  on  any  move to  bring  up  the  move context  menu which  enable  you to  add,  edit  and
remove comments, diagrams, move, evaluation and other symbols.

Move context menu

You can right click on any move in the Game Notation to bring up the move context menu as below:

This menu enables you to  add,  edit  and remove comments,  move and evaluation  symbols.  The following
sections explain how these actions are achieved:

· Comments

· Move symbols

· Evaluation symbols

· Other symbols

To remove the symbols select the remove symbols menu item.
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When you right click to access the Move context menu you are setting the move you right clicked on as the
context. Depending on the context you may have the following options applicable at that point:

· Promote variation - this is used to promote a variation up one level closer to becoming the main line of
the game. When promoting a variation you are in effect demoting any variation it  replaces. Please see
this example:

A main-line and variation:

Promoting the 6...e5 variation has this effect, 6...e5 line is promoted, 6...e6 line is demoted:

· Remove variation - this will delete the current variation, for example::

choosing remove variation on the 6...e5 variation will remove it:

· Remove previous moves - this will remove all the previous moves, for example:

choosing remove variation on the move 2...d6 will remove the previous moves:

· Remove next moves - this will remove the following moves/variations:

choosing remove next on the move 7.f3 will remove the move following it:

Comments

To add a comment select the Add comment...  menu item  from  the  move context  menu.  You can edit  or
remove a comment by clicking on the comment. Either of these approaches will bring up the Edit  comment
dialog where you can add, edit and remove comments and diagrams from the Game Notation.

Move symbols

 
Choose the Add symbol menu item on the move context pop up menu in order  to  select  a  move symbol.
Possible move symbols and their description:

· ! - a good move, usually used for moves that are surprising or clearly better than alternatives

· ? - a poor move. Basically a mistake that should not of been played.

· !! - an outstanding move. Such moves are usually very hard to find and clearly superior to other moves.

· ?? - a very bad mistake. A blunder which normally loses material, overlooks a checkmate or some other
bad outcome.
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· !? - an interesting move but perhaps not the best move available,  this can also be an enterprising move
which  deserves  attention.  Sometimes  !?  is  a  temporary  state  for  a  move  as  with  more  practice  its
symbol can change.

· ?! - a dubious move,  probably  objectively  poor  but  could  be  hard  to  refute  so  has  more  merit  than ?
moves.

· - only move, all other moves are grossly inferior.

Please note setting a move symbol replaces any existing symbol present.  You can also enter the symbols
using the keyboard, for example ! enters !, !? enters !? etc.

You can remove the symbols by choosing the Remove symbols menu item on the Move context menu.

Evaluation symbols

 
Possible evaluation symbols and their description:

· = Equality, a position with equal chances

· ∞ Unclear, a position where it is unclear who if anyone has an advantage.

· += Slight advantage for White

· =+ Slight advantage for Black

· +/− Clear Advantage for White

· −/+ Clear Advantage for Black

· +− Decisive advantage for White

· −+ Decisive advantage for Black

· ∞= With compensation, an unclear position usually where the side down in material has compensation
for the material

Please note setting an evaluation symbol will replace any existing evaluation symbol present.  You can also
enter the symbols using the keyboard, for example = enters =, ~ enters ∞, ~= enters ∞= etc.

You can remove the symbols by choosing the Remove symbols menu item on the Move context menu.
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Other symbols

 
Other symbols which can be added to the game notation moves. This in turn means:

· Zugzwang

· Idea

· Better was

· Novelty - a new move not seen in general practice of this position before

· weak point

· endgame

· bishops of opposite colour

· bishops of the same colour

· severe time control pressure

You can remove the symbols by choosing the Remove symbols menu item on the Move context menu.

Undo/Redo changes

You can undo and redo unlimited operations performed in the Game Notation on the current game since it
was loaded.

Accessed on the Edit menu or via shortcut keystrokes.

HIARCS  Chess  Explorer  maintains  a  record  of all  your  changes  to  the  current  game  notation  since  the
game was loaded. This is extremely useful as it means you can Undo any mistakes you made in changing
the Game Notation,  equally  you can Redo (reapply)  changes  made after  an  Undo provided you have not
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made other changes since you performed the Undo.

Please note the shortcut keystroke for common operations is also defined on the menu,  you can use the
keyboard shortcut to invoke the associated function. For example Ctrl+Z for Undo, Ctrl+Y for Redo.

Game Explorer

Can be toggle accessed by  clicking  the  Game Explorer   shortcut  icon  or  from  the  View->Game

Explorer menu item.

The Game Explorer shows the list of games in the database and provides functions to explore the database
for games. The games are listed under columns describing:

· Game number in database, games are numbered from 1 as they are found in the PGN database.

· White player name and Elo

· Black player name and Elo

· Event where game took place

· Site where game took place

· Round of event game took place in

· Date of game in the format YYYY.MM.DD

· ECO code of opening played in game (this is the Encyclopaedia of Chess Openings code for openings)

· Length of game in moves

Any of these column fields can be sorted. By default the list is sorted in the order the games are in the PGN
database. By clicking on the column header of any field you can sort the list by that column in ascending or
descending order.  In the example below I have sorted the White Elo field into descending  order  by  simply
clicking on the White Elo column header.  This powerful feature immediately gives me the strongest players
who played the white pieces in the AnnotatedGames database:

One of the key features of the Game Explorer pane is the Quick search field which enables powerful quick
searches on the games to be performed.

Quick search

The Quick search field in the Game Explorer pane allows you to create single and range searches from the
keyboard and combine searches to perform powerful filtering of games. The Quick search filter is  applied to
all the games in the database.
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Single searches
· Kasparov    find all games by Kasparov

· Kasparov-    find all white games by Kasparov

· -Kasparov    find all black games by Kasparov

· 2012.06    find all games from last June

· 2011    find all games from 2011

· 1-0    find all games won by white (note: use 1/2 or 1/2-1/2 for draw)

· B17    find all games with ECO B17

· Site:London  find all games played in London (general form is Tag:Value)

·  >2400    find all games with average Elo above 2400

Range searches
· B10-B17    find all Caro-Kann games

· 2001-2011    find all games from XXI century

Combining searches:
· Kasparov- 0-1    find all games lost by Kasparov with white

· Kasparov D80-D99 find all Kasparov games when Grünfeld was played

· Kasparov Karpov find all Karpov-Kasparov games

· Kasparov- -Karpov find all Karpov-Kasparov games where Kasparov was white

· Kasparov Site:London find all games played by Kasparov in London

· Kasparov Karpov Site:London 1-0 0-1 !1/2 find  all  decisive  games  between  Kasparov  and  Karpov
played in London

· Kasparov Karpov !1/2 find all games decisive games between Kasparov and Karpov

· Zvj- Dre find all games with White starting "Zvj" and Black starting "Dre",  matches
Zvjaginsev v Dreev

Opening Explorer

Can be toggle accessed by clicking the Opening Explorer  shortcut icon or from the View->Opening

Explorer menu item.

Opening Explorer is the world's first multi-source real-time chess tree with live updates and automatic game
filtering.

Opening Explorer presents for the current position a statistical view of moves available.  The moves form part
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of a tree of chess positions so it  can track any game and moves played and present in real-time the move
options available and the statistics for those moves from many different sources.

The data presented in the Opening Explorer pane can be sorted by any of the column headers, which can
help depending on how you wish to look at the data.

You can select  multiple  sources  for  the  Opening  Explorer  view.  You select  the  source  from  the  Source:
selector where you can choose from Database, Filter,  Local and Online opening books. With the database
source you can perform real-time game filtering.

The chess tree is automatically updated in real-time in the database and filter source context as games are
added, modified or deleted.

In the Database source context you can also set Opening Explorer to automatically update the games filter
and game list  shown in the Game Explorer pane. This can be a very powerful feature to allow you to  only
see the games appropriate to the opening you are exploring.

With a Filter source context you can have Opening Explorer show only the games of particular  players  or
opponents you might be facing, you can even have Opening Explorer just show moves and statistics  from
your own games. These approaches allow you to have Opening Explorer give an automatic real-time view of
an opening repertoire at any position. 

Move statistics

Opening Explorer  showing the  move &  statistics  for  the  Sicilian  Najdorf  position  using  the  GM+  online
opening book available in the Deep HIARCS Chess Explorer product.

Opening Explorer presents the following statistics against each move:

· Moves - presented in algebraic notation with move symbols assessing the quality of the moves

· Games - the number of games where the move has been played

· Score - the percentage score of the move in practice over those games. The % Score is always given
from White's perspective so it is easier for you to compare moves irrespective of which side is to play.

· Rating - the average Elo rating of the players who played the move

· Performance  -  the  average performance Elo  rating  as  a  result  of  playing  the  move,  this  takes  into
account the average Elo rating of the opponents played and the performance of the move.

· Year - the last year that the move was played in practice in the source games.

· Play% -  an  assessment  of  the  playability  of  the  move.  This  only  appears  on  book  sources  and  is
context related so for GM  books  the  playability  is  specific  to  GMs,  whereas  in  the  highly  acclaimed
HIARCS Tournament book a more narrow assessment of the playability  of the absolute best moves  is
made.
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Each of the columns is sortable in both ascending and descending order.

Sources

Opening  Explorer  can  use  multiple  data  sources  to  present  its  infromation.  The  following  sources  are
available to consult about the current position:

· Database  - the whole database is presented as a tree of moves  available  together  with  the  statistics
from the database itself. This source has the powerful automatic filter option, see the Database source
section for details.

· Filter - the  current  database filter  is  presented as  a  tree  of moves  with  statistics  from  those filtered
games  only.  This  source  is  useful  to  examine  player  or  opponent  opening  repertoires  or  specific
openings or any other filter you can create, see the Filter source section for details.

· Local opening book - the local opening book included is  built  on  Grandmaster  games  and you can
see the moves and statistics for those moves played in Grandmaster games. Only established moves
are shown.

· Online books - the HIARCS Chess Server provides very strong opening books with the latest opening
theory and novelties.  Depending on the product type you can have access  to  a  GM  or  GM+  opening
book with the latest moves and statistics presented. Book subscribers get access to additional online
opening book content.

Database source

When using the Source:  Database in  Opening  Explorer  you are  presented with  the  moves  and statistics
from the database for the current position (whatever that is).

One of of the powerful features of Opening Explorer is the ability  to apply a real-time game filter  based on
the current position. By  clicking  the  Show  games button  you can immediately  set  the  filter  and games
listed in the Game Explorer pane to only show the games which have this position in them. Therefore simply
by clicking the Show games button you will then have a game list  of all the games that contributed to the
moves and statistics shown.

To make the game filter be applied automatically each time you go to a new position in the Game Notation
select the "Automatically set filter" checkbox. With that set the game list will update automatically in real-
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time to show only the games which reach the current position. With  the  filer  set  automatically  the  Show
games button will no longer be required so will not be displayed.

Filter source

When using the Source: Filter in Opening Explorer  you are  presented with  only  the  moves  and statistics
from the filtered database games for the current position on the board. You can narrow the current filter down
to only those games which have the current position in them simply by clicking the Show games button.
Please see the Opening preparation section for details on how Opening Explorer can be used for top class
opening preparation.

In  the  above example  I  searched for  only  games  played by  Garry  Kasparov with  the  White  pieces  with
players over 2600, in that way the Opening Explorer pane can give you the repertoire of a particular player in
any position.

When you see [end] as a move this indicates one of the games ended at this point.

Local source

The local opening book which  is  included with  HIARCS  Chess  Explorer  is  built  on  Grandmaster  over  the
board games. You can view the local book in Opening Explorer which enables you to  see the  moves  and
statistics for the moves played in Grandmaster games. Only established moves are shown. 

Online sources

There  are  various  online  sources  available  within  the  Opening  Explorer  from  the  HIARCS  Chess  Server.
These  online  sources  provide  chess  moves  and  statistics  depending  on  the  product  type  and  book
subscription you have chosen:

· GM - this is a statistical opening book of chess moves played by Grandmaster over the board games.
This online book is available to all customers for at least a year after purchase.

· GM+  -  this  is  a  statistical  opening  book  of  chess  moves  played  by  International  Masters  and
Grandmaster  in  over  the  board  and  correspondence  games.  This  online  book  is  available  to  Deep
HIARCS Chess Explorer customer for at  least a year after  purchase.  An example  of the  Online  GM+
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book is given in the screen shot below.

· Tournament - this is a statistical opening book of chess moves hand tuned from the very best games
played. It has contribution from IMs and GMs and the very strongest chess players. This online book is
available  to  HIARCS  Book  subscribers  and  is  the  same  as  delivered  as  part  of  the  HIARCS  book
subscription and is known to be the strongest commercial opening book and has been for a number of
years.

Each online book is a regularly updated tree of chess moves, statistics and games from different sources.
Updates to the online books are automatically and seamlessly handled by HIARCS Chess Explorer and the
HIARCS Chess Server.

You can access statistics about the online source by moving  the  mouse cursor  over  the  Source  selector
when an online source is selected, you will then see a book stats pop up:

Our online books are updated regularly and we expect to grow our online book sources over time.

Analysis Explorer

Can  be  toggle  accessed  by  clicking  the  Analysis  Explorer   shortcut  icon  or  from  the  View-

>Analysis Explorer menu item.

The Analysis Explorer pane enables you to analyse positions using chess engines, see the analysis from a
number of perspectives and use the analysis in the Game Notation pane.

You can select any chess engine from the engine selector (highlighted in above screen shot),  all engines
which have already been added in the Preferences - Engines tab will be available in this selector.  You will
have the HIARCS World Chess Software Champion engine available in  this  selector  as  it  is  automatically
installed with HIARCS Chess Explorer.
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After you have chosen the engine you want to analyse with you can also set the number of lines to analyse
simultaneously.  Normally  HIARCS  analyses  with  lines=1  to  find  the  best  line  of  play  from  the  current
position, however you may be interested in the top N lines of play, if you are you can set  the lines field to
the number of lines you wish to see simultaneously computed. Please note having lines > 1 makes HIARCS
significantly less efficient at  finding the best move available - ie.  it  will take  somewhat  longer  to  reach the
same depth of search.

The analysis output area is directly under the engine selector.  The output  area  can show analysis  in  four
main ways:
1. Concise view showing only the best move(s) found so far along with the evaluation and depth of search
2. History and Statistic view showing the history of analysis of this position with statistics
3. Game Analysis progress showing the engine analysis progress as it analyses a game
4. Endgame tablebase results showing the results of consulting huge endgame databases.

The Analysis Explorer pane has 4 important shortcut icons next to the engine selector:

Engine settings - this enables you to configure the engine options.

Start/stop analysing - if idle start analysing; if analysing , stop

View  analysis  history  and  statistics  -  toggle  the  view  shown  in  the  Analysis  Explorer

between a clean simple view and the history and statistics view.

Analyse game - this icon button enables you to analyse the whole game with an engine.

Concise view

The concise  view gives  a  very  simple  uncluttered  view of the  engine  analysis  in  Analysis  Explorer.  The
engine analysis is presented as Evaluation/Depth Principle-line

These data values are explained below:.
1. Evaluation in pawns. A positive value is in favour of White and shown in blue, a negative value is in favour

of Black and shown in red. For example +1.00 would indicate White is the equivalent of 1 pawn ahead.
2. Depth of search. This is the depth in half-moves or plies that the engine has searched to.  The deeper an

engine searches the better its analysis result usually is.
3. Principle line - This is the expected line of play the engine expects to occur with best play.

You can insert the evaluation, depth and best line of play into the Game Notation by simply clicking the blue
evaluation and depth  value.  Here  is  an  example  where  the  above analysis  has  been added to  the  Game
Notation pane:
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You can see the expected line of play has been added to the Game Notation with the evaluation and depth
of search. The evaluation and depth of search is added after the first  move of the line so it  is  clear at  which
point in the line the evaluation was computed.

With two lines of analysis the concise view looks like this:

You can also copy the best line or all the lines of analysis to the clipboard by right clicking on the analysis
pane you get this pop up menu:

Any analysis lines copied are copied with piece letters.

History and Statistic view

The History and Statistic view of engine analysis provides the following information in Analysis Explorer:

· Current status of the engine, this shows what move it  is  analysing, the  depth  of analysis,  number  of 
nodes  (positions)  it  has  analysed  so  far  and  the  time  it  has  taken.  Finally  the  average  number  of
positions it  has analysed per second is  given.  It  will  also  show the  number  of accesses  to  the  local
endgame tablebases by the engine in its search.

· The history of analysis given by the engine is given in reverse order so the latest line is always top of the
list.  At each depth searched the engine analysis is given and also if  it  changed its  mind about  which
move was best. The most recent evaluation is always at the top of the list of analysis lines.
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Analysis lines from the engine are given in this order (left to right):
1. Time  -  the  time  at  which  the  engine  output  the  analysis.  We  observe  FIDE  time  format  of

hours:mins.secs, hours are omitted where appropriate.
2. Evaluation in pawns. A positive value is in favour of White and shown in blue, a negative value is in favour

of Black and shown in red. For example +1.00 would indicate White is the equivalent of 1 pawn ahead.
3. Depth of search. This is the depth in half-moves or plies that the engine has searched to.  The deeper an

engine searches the better its analysis result usually is.
4. Principle line - This is the expected line of play the engine expects to occur with best play.

You can insert  the evaluation, depth and best  line  of play  into  the  Game Notation  by  simply  clicking  the
evaluation and depth value (in blue or red). Here is an example:

You can also  copy  the  best  line  or  all  the  history  of  analysis  to  the  clipboard  by  right  clicking  on  the
analysis pane you get this pop up menu:

Any analysis lines copied are copied with piece letters.  When all analysis lines are copied the analysis is
detailed in time order with the latest line at the bottom.

Analyse game

Accessed by clicking the analyse game  shortcut icon in the Analysis Explorer pane. The dialog is

also accessed from the Game->Analyse Game... menu item.

The Analyse game dialog enables you to set up the current selected engine to analyse a  game.  You can
set the following information to control how the game is analysed and annotated:

· Average time per move - this is a guideline time the engine uses per move, over the course of the game
the engine tries to average this time per move. However the engine has the freedom to spend more time
on difficult moves and less time on easy moves.

· Analysis format - you can select Score only or Score and engine name. Both will insert  the evaluation
and depth of search but the engine name is only added to the Game Notation if the engine name format
is selected.

· Annotating engine - you can adjust the annotating engine name to a shorter form which you prefer.
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· Remove previous analysis - if this is checked then any previous analysis by an engine will be removed

· Finally you can select which side of play you wish the engine to analyse the moves of White,  Black or
both sides.

Please note if you analyse the same game with  different  engines  or  with  the  same engine  but  a  different
time per move then it  is  important to set an Annotating engine name to help  distinguish  which  engine  the
analysis came from.

Click OK to begin the game analysis.  The game analysis is performed in reverse order from the end of the
game to the beginning of the game. This helps improve the analysis especially with HIARCS chess engines
which learn from their previous analysis  and can use that  information  of future  outcomes  as  the  analysis
progresses backwards through the game.

As  the  game analysis  progresses  HIARCS  Chess  Explorer  will  use  the  chess  engine's  analysis  of  the
moves and variations to annotate the game with chess symbols to indicate where blunders, poor,  dubious,
interesting and good moves are found and add alternative variations to the Game Notation pane where they
are considered useful.

As the game is analysed the current move being analysed is displayed in the History & Statistics view. For
example:

The progress  of Analyse  Game is  also  shown in  the  progress  bar  at  the  bottom  of  the  HIARCS  Chess
Explorer window. You can also cancel the analysis in progress by clicking the [x] next to the progress bar. 

Endgame tablebase access

Endgame outcome information is available in  endgame databases  called  Nalimov tablebases.  Any  engine
supporting  Nalimov tablebases  can utilise  your  local  endgame  tablebases.  The  folders  to  access  these
databases should be set up in the Engine preferences tab along with the Nalimov cache setting.

While having tablebases stored locally can be useful for analysis,  they do  take  up a  lot  of  storage space
with 6 piece tablebases taking up about 1,000 Gb of storage. Also acquiring all this data can be very time
consuming and even expensive, some retailers sell a small subset of the data on multiple DVDs, yet that 
gives you less than 5% of the data you need.  For many customers this is simply not a practical solution for
them.

With HIARCS Chess Explorer you have automatic online access to about 1,000Gb of endgame databases
with precise information about the  game result  and outcomes  of each move available.  This  information  is
perfect,  it  knows the game result  and if a win  exists  it  can  give  the  number  of moves  to  checkmate  with
perfect play.

In order of obtain this information the "Use Hiarcs server" checkbox must be checked on. This is the default
setting.

Whenever you reach a endgame with  6  or  fewer  pieces  on  the  board  HIARCS  Chess  Explorer  will  try  to
determine the outcome of the game for you. The results if available are displayed in the Analysis  Explorer
pane, here is an example:

This tells  you that with best play in the current position Black can win in 38 moves starting with the move
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77...Rc4.

To see all the move options in the current position and their evaluations click the more...  text  and then the
Online tablebase results dialog will be displayed.

Play game mode

You can launch play game mode from the play game  toolbar icon or the Play->New game...  menu

item.

In play game mode you play a game against the computer. In this mode the access to many features which
are not applicable to this mode are prevented. Instead you have access to operations specific  to game play
e.g. Resign, Offer draw etc, etc. While playing the game you can access the features via the menus or the
play icons which allow you control over the game, moves and assistance.

During play mode if you have Guess move enabled you will have assistance in finding the best  move.  The
quality of moves are highlighted using colour coded square highlights. These can be a great learning aid and
help the playing realise earlier when a move is perhaps not as good as initially  thought.  Of course this can
be turned off in the Preferences->Board tab. Here is an example of the coaching move highlights:
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In addition the coach, if enabled, will watch your play and if it  sees you make a mistake or miss a puzzle
like strong move then it will alert you to this with a coach warning dialog and give you the opportunity to take
back your move or discover the refutation.

Short cut toolbar icons

In a normal database tab you will see the following shortcut icons in the toolbar:

In play game mode the tool bar has the following shortcut icons in the toolbar:

The toolbar icons are made up of the following icon sets, click the set to find out more about them.

· Database icons

· Game icons

· View Icons

· Play icons

Database icons

These database shortcut icons give you quick access to common operations on a database:
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Open a database in a new tab

Show Game Explorer for current database

Show Player Explorer for current database

Search database for games

Load previous game in database

Load next game in database

Load a recent game previously loaded in this database

Game icons

These game shortcut icons give you quick access to common operations on the game:

Create a new game ready for game entry

Set up position to modify the existing position or set up a new position

Edit game header, this gives you the ability  to set or modify the header information for the

game

Rotate the board 180 degrees effectively changing the colour  of  the  player  playing  up  the

board

Go to the start of the game

Takeback last move played in the game

Make the next move in the game

Go to the end of the game
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Replay moves in the game from the current position onwards

Pause/stop the replay of the game. This is only seen during a game replay.

View icons

These shortcut icons give you quick access  to  common operations  affecting  the  presentation  or  mode of
presentation:

Play a game against the computer

Show the Analysis Explorer pane

Show the Opening Explorer pane

Show the Preferences dialog

Play icons

These play game shortcut toolbar icons give you quick access to common operations while playing a game
against the computer:

Pause the game in progress. Stop the clocks (if present) so you can take  a  break.  Click

again to resume.

Force the computer to move immediately when the engine is thinking.

Take back your last move including the computer response.

Replay  your  last  move.  If  you  had previously  performed a  takeback,  this  icon  will  replay

both  your  move  and  the  computer  response.  If  no  takeback  was  performed  this  icon  will  replay  the
computer's last move played. 

Change sides with the computer. You will be asked to confirm this, as you can imagine you

should not do this in a rated game if you want an accurate chess rating.
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Set up position enabling you to modify the current position and even set up a new one.

Toggle  the  coach on or  off.  The  coach  is  on  when  this  icon  is  highlighted.  The  coach

provides move advice and warnings when you make mistakes or miss good moves.

Ask the computer for a hint move. This will be graphical demonstrated on the board.

Short cut keystrokes

You  can  access  many  common  operations  using  shortcut  keystrokes.  The  keystrokes  for  common
operations  are  displayed  on  each  menu.  Please  see  the  section  on  menus  to  discover  the  shortcut
keystrokes for different menu options.

· File menu

· Edit menu

· View menu

· Game menu

· Play menu

· Search menu

· Help menu

Menus

HIARCS Chess Explorer uses menus to access much of its functionality.  Many of the menus have shortcut
key strokes that can be used to access the function from the keyboard. There are also many shortcut icons
which give quick one click access to commonly used functionality.

In this section we look at the menus available and describe the purpose of each menu item.

File menu

The File menu allows you to manipulate files.  Please note  the  shortcut  keystroke for  common operations
are also defined on the menu, you can use the keyboard shortcut to invoke the associated function directly
from the keyboard. You can also see shortcut icons for some menu items on the menu as a guide that there
is a shortcut toolbar icon for the option.

New...
Create a new PGN database, you will be given a New database dialog to set the new database name. The
new PGN database will then be created and opened in a new tab.
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Open...
Open an existing PGN database, you will be given an Open database dialog to select the database to open.
The PGN database will then be opened in a new tab.

Open recent

This menu item gives a submenu of recently opened PGN databases, you will see a list  of  the  databases
you have recently  opened,  you can choose one of these and it  will  be  opened in  a  new tab.  The above
submenu image is an example.

Export

Export  games  to  a  new database,  you can either  export  all  games  in  the  current  database  or  only  the
games in the current filter. An Export games dialog will open so you can set the new database name.

Print

Print the current game or all the games in the filter to the printer.  You will see a print  options dialog where
you can select various parameters including saving the print game(s) to a file.

Close
Close the current in focus tab. Please note when closing a database tab containing a very large database it
takes time to save if changes have been made to that database.

Quit
Quit  HIARCS Chess Explorer,  this will close all currently open tabs. You will be asked to  save or  discard
any modified games. Please note for very large databases which need to be saved it  can take some time to
save all the databases.

Edit menu

The Edit  menu allows you to edit  various aspects of the  program.  Please note  the  shortcut  keystroke for
common  operations  are  also  defined  on  the  menu,  you  can  use  the  keyboard  shortcut  to  invoke  the
associated function directly from the keyboard. You can also see shortcut icons for some menu items  on
the menu as a guide that there is a shortcut toolbar icon for the option.

Set up position...
This allows you to edit the current position or set up a new position. It opens the Set up position dialog.
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Copy

This submenu allows you to copy the current Position shown, the current Game or a selection of Games...
Copying  the  current  Position  to  the  clipboard  allows  you  to  paste  the  position  into  another  tab  or  into
another chess program which supports pasting positions. The Position is copied in FEN format.
Copying the Game to the clipboard allows you to paste the game into another database tab or into another
chess program which supports pasting a game. The game is copied in PGN format.
Copying Games... is a powerful and easy way to copy a selection of games to another database tab in the
GUI.You do need at least one other database open to use the Copy Games...  function. You can read more
about this function in the Copy games section.

Paste

This  submenu allows  you to  paste  a  Position  or  a  Game  from  the  clipboard  into  the  current  tab.  This
enables  you  to  copy  positions  or  games  from  other  programs  or  between  tabs  inside  HIARCS  Chess
Explorer. The Merge with current game menu option enables you to merge a game with the current game
in the Game Notation pane. This is a very powerful analysis feature, you can read more about  this  unique
analysis feature in the Merge game section.

Undo
This option allows you to undo the last operation you performed in this tab on the current game. This is very
useful to reverse mistakes made in Game Notation. There is no limit  to the number of undo operations you
can perform since the game was loaded.

Redo
This option allows you to redo the last operation which was undone by the Undo command above. There is
no limit on the number of Redo commands performed.

Insert

This submenu item allows you to insert into the game notation in a number of ways using the nested menu
items:

· Best move - this option will insert the best move as suggested by the current analysing engine (if one is
running) and change the position to after that move was played and the engine will begin analysing this
new  position.  Depending  on  the  context  of  the  move  to  the  game  notation  the  following  action  is
performed:

o If the move is at the end of the current variation, the move is added to the game notation.
o If  the  move is  new and different  to  that  played in  the  game notation,  a  new variation  will  be

started in the game notation with the move inserted.
o If the move is  the  next  move in  the  game notation  no  new move is  inserted  but  the  position

changes to that after the move was played. 
o Please note if you want to insert  the whole line currently being analysed by the current engine

simply click on the score/depth text value and the whole line will be added as a variation  with
the evaluation and depth. In this case the engine will continue to analyse the current position.

· Null move - this menu item makes a null move in the current position. A null move is basically making
no move therefore giving up the right to move, the opposite side will then be next to play. A null move is
illegal in chess play but is very useful in analysis, for example you may play a null move in a variation to
illustrate what would happen if the side to play does nothing,  thereby  showing possible  threats  of the
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opponent. Please note a null move can also be played on the chess board simply by moving the king of
the side to play onto the opponents king.

· Start  comment....   - this allows you to insert  a text comment before the first  move of the game. It  will
bring up an Edit comment dialog.

· Comment...  - this allows you to insert a text comment at  the current move in the game notation. It  will
bring up an Edit comment dialog. You can also add diagram in the Edit comment dialog.

Please note there are many other context specific items like move, evaluation and other symbols which can
be inserted by right clicking your mouse on a particular move in the Game notation.

Remove

This submenu item allows you to remove from the game notation many different aspects using the submenu
items:

· Current variation - this option allows you to remove the current variation shown in the game notation. It
has no effect on the main line of the game, it only affects variations.

· All comments - this option will remove all the comments from the game notation.

· All variations - this option will remove all variations from the game notation.

· All symbols - this option will remove all move and evaluation symbols from the game notation.

· Everything except  main  line  -  this  option  will  remove all  comments,  variations  and symbols  from  the
game leaving just the main line of the game.

Promote variation
This menu item allows you to promote the current variation shown in the game notation up one level closer
to the mainline. If the variation was only one level down from the main line then the variation would become
the new main line with the previous mainline becoming a sub-variation.

Preferences
This  menu  item  allows  you  to  open  the  Preferences  dialog  where  you  can  configure  HIARCS  Chess
Explorer.

View menu

The  View  menu  allows  you  to  view  various  Explorer  panes  in  the  program.  Please  note  the  shortcut
keystroke for  common operations  are  also  defined on the  menu,  you can use  the  keyboard  shortcut  to
invoke the associated function directly from the keyboard. You can also see shortcut icons for some menu
items on the menu as a guide that there is a shortcut toolbar icon for the option.

Analysis Explorer
This menu item allows you to open the Analysis Explorer pane in the main window. The Analysis Explorer is
used to analyse positions and games.

Opening Explorer
This menu item allows you to open the Opening Explorer pane in the main window. The Opening Explorer is
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used to explore openings and other positions from various sources.

Game Explorer
This menu item allows you to open the Game Explorer pane at the bottom of the main window. The Game
Explorer is used to explore Games in a database.

Player Explorer
This  menu item  allows  you to  open the  Player  Explorer  dialog.  The  Player  Explorer  is  used  to  explore
players, their games and performances in a database.

Flip board
This menu item will turn the board around, for example by default  White is playing up the board, if you turn
the board White will be playing down the board and Black up it.

Game menu

The Game menu allows you perform operations on the current game or select other games. Please note the
shortcut keystroke for common operations are also defined on the menu, you can use the keyboard shortcut
to  invoke the  associated  function  directly  from  the  keyboard.  You can also  see shortcut  icons  for  some
menu items on the menu as a guide that there is a shortcut toolbar icon for the option.

Go to

This submenu allows you to navigate around the current game in the Game Notation pane in various ways
from a submenu with these options:

· Beginning of the game - this option goes to the beginning of the game in the game notation

· Previous 5 moves - this option goes back 5 moves in the game notation

· Previous move - this option goes back to the previous move in the game notation

· Next move - this option goes to the next move in the game notation

· Next 5 moves - this option goes forward 5 moves in the game notation

· End of the game - this option goes to the end of the game in the game notation

· Enter variation - this option brings up a Select move dialog if the there is at  least one variation  on  the
next move

· Exit variation - this option exits the current variation going back to the move before the variation started
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Select

This Game Select submenu allows you to navigate games in the database in various  ways  from  a  nested
menu with these options:

· First - this option loads the first game in the database in the game notation

· Next - this option loads the next game in the database from the current game

· Previous - this option loads the previous game in the database from the current game

· Last - this option loads the last game in the database

· Random - this option loads a random game in the database

· Choose... - this option allows you to select a game number to load from the database

Please note if the existing game in the game notation has been changed and not saved you will be asked if
you wish  to  save it  before  going  to  the  selected  game.  Any  selected  games  which  is  opened  will  then
appear in the game notation pane.

Start/stop analysis
This menu item allows you to start or stop the analysis of the current position by a chess engine. The effect
of this menu items depends on what is currently showing in the Analysis Explorer:

· if the current engine is analysing it will stop analysing

· if the current engine is idle it will start analysing

· If the Analysis Explorer is not currently open, this menu item will open it  and start  the last used chess
engine

Analyse game...
This  menu item  opens  the  Analyse  game dialog  so  you  can  set  the  settings  for  the  current  engine  to
analyse the game. If the Analysis Explorer pane is not open it will be opened. 

New
This menu item starts a new game in this database tab. If the existing game in the game notation has been
changed and not saved you will be asked if you wish to save it  before starting the new game. Please note
this is starting a new game to enter (not to play, you can play games via the Play menu)

Edit header...
This menu item opens the Edit header dialog so you can view or edit the header information for the game.

Save
This menu item saves the current game in the current database replacing the existing game if it  was already
in the database.

Save as new game
This  menu item  saves  the  current  game in  the  current  database making  a  new game entry  for  it  in  the
database. Please note this option should be used with caution since creating another instance of the same
game in the same database will reduce the value of the database statistics used in the Opening Explorer.  It
is also not good practice to have multiple copies of the same game in a database, if you want the duplicate
game for a special purpose, consider whether you should copy the game into a different database for  that
purpose.

Delete
This menu item will delete the current game from the database. This operation cannot be undone so please
use with caution. You will be asked to confirm the deletion:
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Play menu

The Play  menu allows  you to  play  games  against  the  computer  and  perform  operations  on  a  game  in
progress or view played games and ratings. Please note the shortcut keystroke for common operations are
also defined on the menu, you can use the keyboard shortcut to invoke the associated function directly from
the keyboard. You can also see shortcut icons for some menu items on the menu as a guide that there is a
shortcut toolbar icon for the option.

New game...
This menu item allows you to  start  a  new game to  play against  the  computer,  it  opens  the  Play  new
game dialog so you can set the conditions for the game.

Takeback
This menu item allows you to takeback a move during the game. It takes back both the computers response
and your last move.

Switch sides
This menu item allows you to change sides with the computer.  Please note for rated games if you want an
accurate chess rating we suggest you do not use this option.

Offer draw
This menu item allows you to offer a draw to the computer.  The computer will consider your draw offer and
either agree to the draw or refuse it and choose to play on.

Resign
This menu item allows you to resign the game. Your opponent will be awarded the win.

Pause
This menu item  allows  you to  pause the  current  game,  the  clocks  will  be  paused.  You can resume the
game by selecting this menu item in paused game condition and the clocks will restart.  Very useful if you
need a break during the game. 

Move now
This  menu  item  forces  the  computer  to  stop  thinking  and  make  its  move.  It  only  has  an  effect  if  the



59 / 92

computer is thinking.

Hint
This menu item requests a hint  move from the computer.  The hint  move with be animated on the board so
you can see what move the computer is suggesting.

Coach
This menu item allows you to toggle the coach on or off.  When on the coach will warn you if it  thinks your
move might  be  a  serious  mistake and the  coach can even alert  you  to  the  possibility  that  you  may  of
missed a very strong move.

View played games
This menu item will open the  PlayedGames  PGN database in  a  separate  database tab  so  you can view
games you have already played against the computer.

View rated users...
This menu item will open the Rated users dialog where you can view the  current  chess  ratings  of players
who have played games in HIARCS Chess Explorer.

Search menu

The  Search  menu  allows  you  to  perform  searches  on  games  in  databases.  Please  note  the  shortcut
keystroke for  common operations  are  also  defined on the  menu,  you can use  the  keyboard  shortcut  to
invoke the associated function directly from the keyboard. You can also see shortcut icons for some menu
items on the menu as a guide that there is a shortcut toolbar icon for the option.

Quick search
This menu item will open the Game Explorer (if necessary) and give focus to the Quick search element of
the  Game Explorer  so  you can enter  quick  search  terms  to  find  games.  For  details  on  what  the  Quick
search field can do please refer to the Quick search section.

Header
This menu item will open the Header Search dialog so you can specify a search filter of the game header.
The searching and filtering capabilities of the program are very powerful, you can read more in the Searching
and filtering section.

Position
This menu item will open the Position search dialog where you can specify a chess position to search for.

Reset filter
This menu item allows you to reset the header search filter - all values previously used are cleared. The filter
will now match all games in the database.

Reverse filter
This menu item allows you to  reverse  the  search  filter  so  only  games  not  matching  the  original  filter  are
matched. This can be used as part of advanced filtering as explained in the Searching and filtering section.

Help menu
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The Help  menu allows  you to  access  help  manuals,  context  sensitive  help  and  enquire  about  updates.
Please note the shortcut keystroke for common operations are also defined on the menu, you can use the
keyboard shortcut to invoke the associated function directly from the keyboard.

HIARCS Chess Explorer Help
This will launch the HIARCS Chess Explorer manual in  Windows HTML Help.  The manual  is  searchable,
has a detailed contents and the manual is written to enable easy navigation around it.

Context help
While using HIARCS Chess Explorer it  is  possible to  bring  up  context  sensitive  help  by  using  this  menu
item  or  the  F1 keystroke.  Context  sensitive  help  gives  you  help  information  about  the  window,  pane  or
function you are currently using. The menu can only give context sensitive help on  the  main  window.  Use
the F1 key to access context sensitive help from a dialog.

About HIARCS Chess Explorer
This menu item shows information about the product. The About HIARCS Chess Explorer dialog also allows
you to update your license.

Check for updates
This menu item will launch a browser to contact www.hiarcs.com to see if any update is available for your
version of HIARCS Chess Explorer.

Recent game pop-up menu

Accessed by clicking the recent game shortcut icon 

HIARCS Chess Explorer keeps a record of recently visited games in each database so it  is  easy to revisit
games previously viewed in the database by using the recent game icon. Click the icon and you will be given
a menu of recent games with game number in database, player names and result, here is an example:

You can then select the game you wish to load.

Filter pop-up menu

In the bottom right hand corner of the main window the  number  of filter  and database games  is  given,  for
example:

This shows you that the Game Explorer pane is showing 287 out of 34191 games. The current filter contains
those 287 games.

You can right click on the filter/database games number to pop-up the Filter menu:
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Reset filter
This menu item allows you to reset the header search filter - all values previously used are cleared. The filter
will now match all games in the database.

Reverse filter
This menu item allows you to  reverse  the  search  filter  so  only  games  not  matching  the  original  filter  are
matched. This can be used as part of advanced filtering as explained in the Searching and filtering section.

Display dialogs
There are many display dialogs used in HIARCS Chess Explorer. This section explains the meaning of each
main dialog and how it is reached.

New database

This New database dialog is  accessed from  the  File->New...  menu item.  It  enables  you to  create  a  new
PGN database. Enter the file name of the database you wish to create and click Save.
You can also browse to another folder if you wish to create a PGN database in a different folder.

Open database
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Accessed by clicking the open database  shortcut icon.The dialog is also accessed from the File-

>Open... menu item. It enables you to open a PGN database. Click the PGN database you wish to load and
click Open (alternatively you can double click the PGN database file name to open it).

This dialog will open the last folder  you opened a  database from.  Initially  it  will  show you the  Databases
folder which contains all the databases delivered in the HIARCS Chess Explorer package.  You can easily
browse to another folder if you wish to find a PGN database not in the HIARCS Chess\Databases folder.

When you first  open a database it  will  automatically  open the  Game Explorer  pane so  you can view the
games in the database.

Please note for very large databases it  can  take  some time to  load all  the  games  and build  the  required
views of the data.

Set up position
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Accessed by clicking the set up position  shortcut icon.The dialog is also accessed from the Edit-

>Set up position menu item. The Setup Position dialog allows you to edit  an existing position or set  up  a
new position altogether.

The dialog shows the following information:

· The current board position of the edit

· The current side to move in the position

· The move number of the position

· The current FEN of the position at the bottom of the dialog

· On the right hand side there is a palette of chess pieces to select from

Changing the position
You can change the position in a number of ways:

· You can drag any piece to another square to move it

· You can drag any piece off the board to remove it

· You can select any piece/colour from the palette:
o  then click on one or more squares to add the piece on that square
o if you click on a square which already contains that piece/colour it  will  be  removed  from  the

square leaving it empty
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Operation buttons
There are a number of buttons to perform actions on the position:

· Clear button will clear the board of pieces leaving an empty board

· Reset button will reset the position to the opening chess position

· Paste FEN will paste a FEN position from the clipboard onto the board

· Copy FEN will copy the current board position shown onto the clipboard

· Cancel will cancel the position set up and return to the game window

· OK will accept the position set up and return to the game window with the new position

Advanced
In the advanced tab you can adjust:

· the Castling rights of the current position shown in the Board tab - please note in any position HIARCS
Chess Explorer will initially set the most likely castling rights for the position.

· set the number of plies (half moves) since the last capture or pawn move.

Export games

This Export  games dialog is accessed from the File->Export->menu item. It  enables you to select  a  PGN
file name to export the games to. Enter the file name of the database you wish to export to and click Save. 
You can also browse to another folder if you wish to export  to a PGN database in a different folder.  Please
note Export  games will create a new database. Therefore if you choose an existing  database to  export  to
you  will  be  warned  that  the  database  will  be  replaced.If  you  intended  to  copy  games  to  append  to  a
database then use the Copy games... menu option.

Copy games
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This Copy Games dialog is accessed from the Edit->Copy->Games...  menu item.  It  enables  you to  copy
game(s) from the current tab and paste those game(s) to another database which is open in another tab of
HIARCS Chess Explorer.
You can select to copy just a single game, the games in the current filter or all  the  games  in  the  current
database.
To choose the database to paste to click the database name in the To: list and then select OK.
The game(s) will then be copied to the database you selected.

Edit comment

This  Edit  Comment  dialog  is  accessed from  the  Edit->Insert->Comment...  menu item.  It  enables  you  to
enter a new comment after any move in the game notation, the comment is inserted after the current move
shown in the Game notation pane. If you wish to enter a comment at  the start  of the game you can select
the Edit->Insert->Start comment... menu item.

You can also edit  any existing comment by simply clicking on the comment  in  the  Game Notation  pane.
You can then edit it in this Edit comment dialog. While editing a comment the comment will be underlined in
the Game Notation pane.

You can clear an existing comment by using the Clear button. 

To add a diagram to the Game Notation for later printing select the Add diagram button. The diagram will be
added at the cursor position within the text so you have flexibility  about diagram placement within the text
comment. This allows great flexibility over the printed game.

Player Explorer
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The Player Explorer dialog is accessed from the View->Player Explorer menu item or the shortcut

icon. It can also be accessed by clicking on a players name in the Game Notation header information.

Player Explorer is a powerful way to view the players in a database, their games, performances and favourite
openings.

The dialog is composed of 

· a Players tab which enables you to find players in the database

· an Information tab which enables you to see details about the player selected

The Show player button will show details about the current selected player in the Information tab. 
The Update  list button can be used to  update  the  statistics  if  you  have added,  modified  or  deleted  any
games to this database since the Player Explorer dialog was opened.
The Close button exits the dialog.

Players tab view
The Players tab view enables the selection of a player in order to view detailed information about the games,
performances and openings of the player or whole database. Please see the Players tab  section  for  more
details.

Information tab view
The Information  tab  view shows  the  detailed  information  about  the  selected  player,  their  games,  results,
performance and favourite openings. Please see the Information tab view section for more details.

Players tab view
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When you first  open Player  Explorer  you  will  see  a  list  of  the  players  who  have  played  games  in  the
database. The top entry is always the entire database and this can give an excellent overview of the games
in the database.

To find a specific player you can either scroll through the list of players or more conveniently enter the name
of the player you are interested in, as you enter characters in the Find: field,  the Player Explorer will narrow
down the choices of players in the list  to aid your quick selection. Player Explorer uses whatever you type
to search the database of player names and give those that match.

To select a player or the whole database you can click on the appropriate player and click the Show player
button  to  view the  details  about  that  player.  Alternatively  if  you  double  click  a  player  from  the  list,  the
Information tab will automatically open to show you those details.

The Update  list button can be used to  update  the  statistics  if  you  have added,  modified  or  deleted  any
games to this database since the Player Explorer dialog was opened.
The Close button allows you to exit the Player Explorer dialog.
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Information tab view

The Information tab shows detailed information about the selected player,  their games, results,  performance
and favourite  openings.  This  dialog  is  a  very  powerful  navigation  aid  for  chess  players  so  we  will  try  to
explain it in detail. If you have a game open in the Game Notation pane with the player you are interested in
you can click the player name to access this Player information directly.

Here we see the details for English GM Michal Adams. It shows the following information in order:

· Players name, in the included databases we use the official FIDE names where available.

· Number of games played by the player in the named database

· The date range when the games were played

· The rating of the player over that period

Now we come to the player statistics.  The statistics marked in blue are  selectable  and clicking  them  will
automatically  populate  the  Game Explorer  game list  with  the  games  matching  the  criteria,  for  example
clicking on the +155 games in the White: line will show the 155 white wins by Michael Adams in the game
list. This innovative hyper-linked connectivity between Players and Games is a very powerful and convenient
mechanism to rapidly access games.

Let us look the remaining information:

· Total games played split into wins, draws and losses.

· White games and their statistics - these are games played by Michal Adams as White, you will see the
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performance % for Michael Adams playing white is also given at 59.6%

· Black games and performance statistics

· Opening statistics  show the  8  most  popular  openings  the  player  played  with  the  White  and  Black
pieces.

Under the player's opening statistics section you can again click any statistic marked in  blue  to  populate
the Game Explorer game list  with the games matching the criteria,  for example clicking on  the  54  games
next to Sicilian Defence, Najdorf  will show those games involving Michael Adams where the Sicilian Nadjorf
opening was played. This innovative hyper-linked connectivity between Players, Openings and Games is  a
very powerful and convenient mechanism to rapidly access games in particular openings.

The opening  statistics  are  particularly  useful  if  you  are  interested  in  a  particular  opening  or  a  particular
player and the openings they play. This is very useful for preparation.

When you view the  Information  tab  for  the  database you get  an  overview  of  the  games  played  in  the
database, here is an example from the TopGames database:

Here you can see the overall statistics including wins, draws, losses and unfinished games.
The opening  statistics  are  very  interesting  and  cover  the  whole  database  showing  the  20  most  popular
openings for white or black. 

You can click any hypertext in blue and HIARCS Chess Explorer will populate the Game Explorer game list
with the games matching the criteria,for example clicking the +274 on the Grunfled Defence Classical  line
will show all the white wins in the Classical Grunfeld opening in the game list. This innovative feature gives a
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powerful instant connection between Players, Openings and Games and a convenient mechanism to rapidly
access games in particular openings.

The Update  list button can be used to  update  the  statistics  if  you  have added,  modified  or  deleted  any
games to this database since the Player Explorer dialog was opened.

Analyse game

Accessed by clicking the analyse game  shortcut icon in the Analysis Explorer pane. The dialog is

also accessed from the Game->Analyse Game... menu item.

You can see a description of this dialog in the Analyse game section of Analysis Explorer

Edit header
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Accessed by clicking the Edit  header  shortcut icon.The dialog is also accessed from the  Game-
>Edit  header...  menu item. This dialog is also presented when you save a  game where  the  game header
needs to be defined.

The dialog enables you to change the header fields of the game. It is important to set the correct values for a
game as it  makes it  easier to find the game later.  You can set all the mandatory fields of a PGN game in
this dialog, it also allows you to edit/add new tags in the Extra tags tab.
Please note you can set a date either by entering it  or using the built  in calendar by clicking the calendar
icon. PGN dates are in YYYY.MM.DD format.

Save game

This Save game dialog is  accessed from  the  Game->Save menu item  when you save a  new game.  This
dialog is also presented when you save a new game using the floppy disk icon in the Game Notation pane.
It enables you to set the header fields for a new game. It is important to set the correct values for a game as
it makes it easier to find the game later. You can set all the mandatory fields of a PGN game in this dialog,
it also allows you to edit/add new tags in the Extra tags tab.
Please note you can set a date either by entering it  or using the built  in calendar by clicking the calendar
icon. PGN dates are in YYYY.MM.DD format.

Save game as
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This Save game as dialog is accessed from the Game->Save as menu item.
It enables you to set the header fields for a new game. It is important to set the correct values for a game as
it makes it easier to find the game later. You can set all the mandatory fields of a PGN game in this dialog,
it also allows you to edit/add new tags in the Extra tags tab.
Please note you can set a date either by entering it  or using the built  in calendar by clicking the calendar
icon. PGN dates are in YYYY.MM.DD format.

Play game
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Accessed by  clicking  the  Play  game  shortcut  icon.The dialog  is  also  accessed from  the  Play-

>New game...  menu item. This dialog enables you to configure the type of game you wish to play against
the computer.

There are many sections to the Play game dialog, here is an explanation of each:

Player
This section allows you to enter the name of the player who will play the game (it defaults to your name).
You can access Rated users statistics by clicking on the ...  button next to your name, this will display the
Rated user dialog.
You can choose if you want the game to be a rated game. The player's current rating is also displayed, here
it is 1600 Elo.

Opponent
This  section  allows  you to  select  your  opponent.  Any  engine  loaded  into  HIARCS  Chess  Explorer  can
selected, however not all engines support set Elo ratings like HIARCS chess engines.  Also no other chess
engine supports the play realism of the HIARCS chess engines.
You can select the rating of your opponent:

· Maximum setting allows the engine to play its strongest chess

· Match player  strength  allows  you to  play  an  adaptive  opponent  which  matches  your  estimate  chess
strength

· Custom allows you to set a specific Elo rating for the engine to play at. The up and down arrow selector
will increase or decrease the value in 25 Elo steps. You can of course  click  on  the  value  and set  an
exact value from the keyboard.

If you want your opponent to also think about its next move while it is your turn to move you can turn this on
or off using the Think on player's time checkbox.

Time control
You can optionally choose a time control to play at. Here are the options:
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· No time control selected - the opponent will move instantly, nice for casual play.

· Time per game - you can set the time which each side has to complete all their moves

· Time  per  game  with  increment  -  the  same  as  Time  per  game  except  in  addition  you  can  set  an
increment in time each player gets for each move they make

· Time per given moves - this allows you to set the number of moves each side must complete in a given
amount of time

In addition to these time control settings you can also set extra time on the players clock at the start  of the
game.

Non standard starting position
This is a powerful option which allows you to set a non standard  starting  position  which  is  very  useful  for
practice and learning. 

You can select either the current position from the database tab  when you started  Play->New game...  or
you can select from a huge range of chess openings that you may wish to practice against.  Please see the
Learning to play openings section for details.

Colour
This allows you to set the colour you wish to play, select White or Black  or  allow a  random  colour  to  be
selected.

Play realism

HIARCS chess engines use new play realism capabilities which give a much more realistic human like feel
to the play of the weaker set Elo opponents in the HIARCS chess engine. In particular it tries to produce the
same sorts  of  mistakes  and common moves  that  weaker  players  are  prone to.  This  enables  you to  get
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genuinely  useful  practice  against  our  handicap  opponents  as  they  will  challenge  you  very  much  like  a
human player  of  that  strength  while  making  similar  mistakes  to  players  of  that  strength.  In  addition  it
matches the opening book moves to the playing strength and even forgets its book moves or mixes up move
orders to simulate real play.

Coach warnings

Coach warning: Mistake made
While playing a game against the computer when the coach option is enabled, the coach will warn you if the
it thinks one of your moves is a mistake. You will then see the following dialog:

You can then have the coach show you the refutation by clicking the Show refutation button.  The refuting
move will  then  be  demonstrated  on  the  board.  You  have  two  options,  you  can  Ignore  the  coach  and
continue playing  or  accept  the  coach  advice  and  takeback  the  move.and  consider  your  previous  move
again.

Coach warning: Very good move available
As well as pointing out mistakes the coach can spot when you have missed a very good move when it  will
display a dialog like the following:

Again you have two choices, to accept the coach advice and takeback your move and look for the one very
good move available - if after looking for sometime you cannot find it but really want to know what move it  is
you can click the hint  icon  to  have the  move demonstrated.  Alternatively  you can ignore  the  coach and
continue playing.

Coach warning: Mistake played and very good move available
It is possible that the move you made was a mistake and also one very good move exists.  In this case the
Coach gives you the following warning dialog:



76 / 92

You  can  ask  the  coach  to  demonstrate  the  refutation  of  the  move  you  made  by  clicking  the  Show
refutation button.The refuting move will  then be demonstrated  on the  board.  You have two options,  you
can  Ignore  the  coach  and  continue  playing  or  accept  the  coach  advice  and  takeback  the  move.and
consider your previous move again.

Computer resignation

During game play if you manage to reach an overwhelming advantage the computer will offer its  resignation.
You can accept  the  resignation  and the  game will  end in  your  favour,  alternatively  you may  want  to  not
accept the resignation but play further if you would prefer to get practice finishing off your opponent.  If you
choose to play further the computer will not resign again so you will have prove the win by check mating the
computer.

Resign or offer draw

While playing against the computer in play game mode you can resign the game or ask the computer for a
draw.

Resign
You can resign a game by selecting the Play->Resign menu item. When you resign a game you are giving
victory  to  your  opponent,  the  game will  be  over.  You should  resign  if  your  position  is  hopeless  and  you
believe your opponent is strong enough to prove the win.

Offer draw
You can offer  a  draw to  the  computer  by  selecting  the  Play->Offer  draw  menu  item.  Depending  on  the
computer's  assessment  of  its  position  it  will  either  agree  to  the  draw  to  reject  your  draw  offers.  If  the
computer wants to play on it will inform you as follows:

You should play on as the computer does not want a draw.
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If the computer agrees to the draw you will see:

The game is now finished.

Abandon game

When you click the X on a Play game tab, it  means you want to abandon the game. You will then see the
Abandon current game dialog above. If you choose the Keep playing button you can resume playing the
current game as if the X was not clicked.

If you wish to Abandon the game you first need to decide how you want the game abandoned. Here are the
options:

· Save as 1-0 - Game will be saved as a White win

· Save as 0-1 - Game will be saved as a Black win

· Save as 1/2-1/2 - Game will be saved as a draw

· Save as * - Game will be saved as an unfinished game (no result assigned)

· Don't save - the game will not be saved

HIARCS Chess Explorer examines the current position and makes the default  selection the one it  expects
you will want to make

Choose the appropriate game outcome/action and click the Abandon button to abandon the game. 

Out of time

When playing a game against the computer using a time control, if you run out of time you will see the Out
of time dialog:
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You are given the choice:

· Resign the game - after all you lost the game on time

· Continue the game by adding time to your clock

Rated users

This Rated users dialog is accessed from the Play->View rated users... menu item.
It shows the current users who have ratings, the number of games played and the results so far achieved.
Please see our Elo Ratings section for an explanation of ratings.

Header search
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Accessed by  clicking  the  Header  search   shortcut  icon.The  dialog  is  also  accessed  from  the

Search->Header menu item. This dialog allows you to search the current database for games matching the
search criteria, the search results are known as the as the search filter.

You can specify any of the fields in the dialog to search for, or leave them blank to indicate match all for that
field. You can use the Ignore colours checkbox to indicate that the White and Black fields can also apply to
Black and White thereby matching both colours.

As you type a name in the White, Black, Event or Site field HIARCS Chess Explorer will aid your selection
by giving you possible values based on what you type, this is a great help in remembering difficult  names or
events etc.

Incomplete fields are treated as the first part  of a wildcard, for example type "Ka" in the White field will find
all  players  with  a  name  beginning  with  "Ka"  like  Karpov,  Kasparov etc.  Here  is  an  example  from  the
TopGames database when typing "An" in the White field,  you will see only the possible names match "An"
are offered making it much easier to name players correctly:
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You can specify an elo range for each player.  You can even specify the date range for the search down to

an exact date range including days. The integrated calendar selector is accessible from the calendar 

icon which allows you to easily do this.

Finally you can specify how the search will be applied:

Search all
The default is  to Search all games in the  database and create a new search result  filter of the the games
found. The search result will be listed in the game list of the Game Explorer pane.

Search filter
This enables you to search the games in the current filter only. It  will create a new search result  filter out of
the the games found. The search result will be listed in the game list of the Game Explorer pane.

Add to filter
This enables you to search  all  games  in  the  database and add the  search  results  to  the  current  filter  of
games. The combined results will be listed in the game list of the Game Explorer pane.

Search for position

The Search for position dialog is accessed from the Search->Position menu item and enables you to set a
position so that you can find all games in the database which have that position.
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Initially the dialog uses the current position displayed on the main board. All the editing abilities of the Set
up position dialog are possible here including moving pieces around. 

You can use the Paste  FEN button to paste a position from the clipboard into this dialog to quickly set a
position you want to search for.  Equally from any position set you can copy  the  position  to  the  clipboard
using the Copy FEN button. The current position in FEN format is displayed at the bottom of the dialog.

The Clear button enables you to clear the board of pieces so you can set a completely new position from
scratch to search for. The Reset button will set the normal opening position.

The Cancel button will abort the dialog and not perform a search.

Once you click the OK button,  HIARCS Chess Explorer will search  the  current  database for  the  position
and display the games in the game list in the Games Explorer pane.

Please note  Opening  Explorer  also  provides  a  real-time  position  search  capability  from  positions  in  the
Game Notation. Please see the Opening Explorer section for details.

Preferences

Accessed by  clicking  the  preferences  shortcut  icon.  The dialog  is  also  accessed from  the  Edit-

>Preferences menu item.

This dialog can be used to configure the preferences for HIARCS Chess  Explorer.  The preferences  fit  into
three broad categories each covered by a tab view:
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· Board configuration tab allows configuration of the chess board and chess set presentation, and engine/
coach highlights.

· Engines configuration tab allows configuration of the chess engines used and common data they use.

· Advanced configuration tab allows configuration of miscellaneous settings.

When the preferences are configured the settings remain set each time you run the program until you next
change them.

Clicking the Apply button will apply the current settings but keeps  the  dialog  open.  Clicking  the  Cancel
button will cancel  any  changes  since  the  last  apply  and exit  the  dialog.  Finally  click  the  OK button  to
apply the current settings and exit the dialog back to the main display.

Board Preferences

The Board tab of the  Preferences  dialog  enables  you to  configure  the  board,  chess  set  and highlighting
aspects of HIARCS Chess Explorer.

You can set the chess set you like from the Alpha, Leizig,  Merida and USCF chess sets.  Each chess set
can be presented as Plain, with an Outline or with an Outline and Shadow.

The actual chess board can be set to multiple different  textures  including  wood,  marble,  stone,  slate  and
solid colours. You can see below some of the piece and texture combinations:
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Any changes you make to the Chess set or Board style will be reflected in the sample chess board in the
Board tab.  This enables you to see what the combination of boards and chess  sets  look  like  before  you
decide on your preference.

You can also change the highlight colours for the highlighted moves by clicking on the highlight colours you
will get a colour palette to set your preferred colour.

You can also adjust the presentation of coordinates around the  board.  This  setting  will  also  affect  printed
diagrams.
A  frame around each square  on  the  board  can also  be  set  on  if  you  prefer  the  look.  The  Guess move
provides automatic intelligent guess moves for pieces during  game entry  and guidance during  game play.
This can be a very powerful aid but if you prefer  not  to  receive  this  assistance you can turn  off  the  move
guesses.

Finally  the  last  engine  move  can  be  highlighted  although  we  have  left  this  off  by  default  as  the  move
animation given by HIARCS Chess Explorer highlights the last move of an engine well.

Clicking the Apply button will apply the current settings but keeps  the  dialog  open.  Clicking  the  Cancel
button will cancel  any  changes  since  the  last  apply  and exit  the  dialog.  Finally  click  the  OK button  to
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apply the current settings and exit the dialog back to the main display.

Engine Preferences

The Engines tab of the Preferences dialog handles  adding, configuring and removal of chess engines.
As  part  of  the  HIARCS  Chess  Explorer  package  you  will  have  the  HIARCS  14  World  Chess  Software
Champion engine(s) available automatically installed and added. You can also add any other UCI compatible
engine.

Clicking the Apply button will apply the current settings but keeps  the  dialog  open.  Clicking  the  Cancel
button will cancel  any  changes  since  the  last  apply  and exit  the  dialog.  Finally  click  the  OK button  to
apply the current settings and exit the dialog back to the main display.

At the bottom of the dialog are the common settings applied to each engine for:

· Hash table  size  -  this  is  a  search  table  chess  engines  use to  cache positions.  The value  is  set  in
Megabytes (MB), for general use 256Mb is a good size to use. In general do not use more than 50% of
the physical RAM on your machine. The up/down arrows allow the adjustment of the Hash table size in
values which are powers of 2 (e.g. 64Mb, 128Mb, 256Mb). Alternatively,  you can click on  the  value  to
enter an exact Hash table size.

· Nalimov tablebase path  -  this  is  the  path  to  local  tablebases  for  the  engines  to  use,  you can set
multiple paths by clicking the Add.. button.

· Nalimov cache size - this is the size of an endgame cache of Nalimov tablebase positions. If you have
all  4,5  &  6  piece tablebases  then use 512MB  or  more.  For  5  piece  tablebases  you  can  use  less,
e.g.128MB. For just 4 piece tablebases 32MB is enough. The up/down arrows allow the adjustment of
the Nalimov cache size in values which are powers of 2 (e.g. 64Mb, 128Mb, 256Mb). Alternatively,  you
can click on the value to enter an exact Nalimov cache size.

The Nalimov tablebase path  can be set  by  clicking  on  the  ...  button  when  you  will  be  given  a  Choose
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directories dialog:

you can then browse to the folder(s) where you have the tablebases stored and you can Add each folder that
contains tablebase files. You can also edit and remove folder paths and change the order of them.

Add an engine
To add a new engine (only UCI chess engines are supported) you simply click the Add...  button and you
will be given a Select engine executable dialog to browse and find the engine to add. Please see the Add an
engine section for details.

Configure an engine
To configure an engine's options have the engine highlighted in the engine list  of the preferences dialog and
select the Configure... button. You will then be presented with an engine configuration dialog:

Remove an engine
To remove an engine highlight the engine you want to remove in the engine list  by clicking on it.  Then click
on the Remove button and the engine will be removed from the engine list.  Once the engine is removed it
will no longer be available for selection in Analysis Explorer or in Play game mode.

Add an engine
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 In the example above we are adding a Hiarcs 13.2MP engine:

You browse to the folder containing the  chosen engine  and click  on  the  engine  executable  and it  will  be
added as an engine to the Engine list of the Preferences->Engine tab. Once added you can later select the
engine in the Analysis Explorer pane or Play game engine selector.

Some engines may require prior registration before use or registration on first  use. Please take note of the
instructions with each chess engine.

Please note the HIARCS 14 World Chess  Software  Champion engine  is  automatically  added by  HIARCS
Chess  Explorer  when  it  starts  for  the  first  time.  In  addition  your  HIARCS  Chess  Explorer  license  will
automatically activate the HIARCS chess engines applicable to your license.

Configure engine
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The Configure dialog lists all the options of the engine in alphabetical order. Engine options which are read
only  are  displayed greyed out  (for  example  Book  Positions).  Options  that  are  changed  from  the  default
values are displayed in bold (for example Book Mode has been set to Surprise).
Some engines like HIARCS give About information which is available by clicking the question mark icon.
If you are happy for the engine to use the common hash settings in the Engines tab then check the  "Use
common hash settings" box. If that  is  unchecked you will  be  able  to  set  the  hash in  the  engine  options
specifically for this engine. Some options are action buttons, these are grey/blank when the  engine  is  not
currently loaded, when the engine is running the action buttons are enabled. 

Advanced Preferences
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The Advanced tab of the Preferences dialog handles miscellaneous configuration settings in the following
areas:

Appearance
You can set the language used by HIARCS Chess Explorer.  You should not normally need to use this as
the default OS language is used in HIARCS Chess Explorer when it starts.

The  Piece  format  can  be  changed  to  use  either  Figurine  (default)  or  Piece  letters.  Please  note  when
analysis is  copied  from  the  Analysis  Explorer  it  is  always  copied  with  Piece letters  to  avoid  font  issues
when pasting analysis lines in other software.

The Game font can be changed and that font is  used in the game notation. The fonts for the game list  and
opening explorer move list is displayed using the default font size set in the OS preferences.

Databases
Databases are auto saved every 10 minutes by default, you can modify this if you wish.

If the Overwrite existing ECO codes checkbox is set the following actions apply:

· when a database is loaded into HIARCS Chess Explorer the  openings  are  automatically  classified  for
their ECO opening code overwriting any ECO code already set.

· any games added will have the ECO code classified by HIARCS Chess Explorer and the ECO field will
be read-only.

When Overwrite existing ECO codes checkbox is unset the following actions apply:

· when a database is loaded into HIARCS Chess Explorer the ECO only classified if it is  not present,  any
existing ECO value in the database is never modified

· when you save a  game HIARCS  Chess  Explorer  will  populate  the  ECO field  if  it  is  empty.  You can
always edit the ECO field.
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If  you  prefer  to  keep the  original  ECO code assignment  already  in  PGN databases  please uncheck  this
option.

Online sources
By  default  HIARCS  Chess  Explorer  will  contact  the  HIARCS  Chess  Server  (HCS)  to  retrieve  information
about  openings  and  endgames  which  are  displayed  by  Opening  Explorer  and  Analysis  Explorer  as
appropriate. If you want stop access to the HIARCS Chess Server this option can be unchecked.

The  book  license  field  allows  HIARCS  Opening  Book  subscribers  to  access  additional  content  in  the
Opening Explorer.  A valid book license will enable access to powerful new opening books on the  HIARCS
Chess Server. For security reasons actual licenses are never displayed and are always encrypted.

Troubleshooting
In the unlikely event you need to troubleshoot an engine added to HIARCS Chess Explorer you can set this
option. An engine.log  file  will  then be generated  in  the  HIARCS  Chess/Explorer  folder  with  details  of  the
communication between the GUI and engine. This option will only be applied until you exit  HIARCS Chess
Explorer when the  option  is  unset.  This option  should  only  be  set  by advanced  users and  only  for
troubleshooting an engine as it will affect the performance of any engine used.

Clicking the Apply button will apply the current settings but keeps  the  dialog  open.  Clicking  the  Cancel
button will cancel  any  changes  since  the  last  apply  and exit  the  dialog.  Finally  click  the  OK button  to
apply the current settings and exit the dialog back to the main display.

Select move

When stepping through a game using the Ctrl+right arrow  key,  HIARCS  Chess  Explorer  will  give  you a
choice when you reach a position which has more than one move option (ie.  where there a variations).  The
Select move dialog shows the move choices with the main continuation shown in bold. You can select the
next move using the mouse, using the keyboard letter for the variation (here A, B or C) or using the  arrow
keys, up or down to change the choice and the right arrow or enter key to select the move.

Promote to

When a pawn reaches the eighth rank you will see the Promote to dialog displayed:
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Please select the piece you wish to promote the pawn to. If you want to cancel the promotion move and
take it back, click Cancel.

Tablebase results

When you reach an endgame position and HIARCS Chess Explorer has displayed in the Analysis Explorer
an endgame database result, for example as follows:

you can choose to  see more...  in  order  to  view  all  the  move  options  in  the  current  position  and  their
outcomes. You will then be presented with the Online tablebase results dialog, here is an example:

You can see the move choices and the outcomes of each move available in the current position.

About HIARCS Chess Explorer
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This dialog is accessed from the Help->About HIARCS Chess Explorer menu item
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Support

For  support  you should  first  read the  appropriate  section  of  this  manual  and  the  context  sensitive  help
available within HIARCS Chess Explorer.

If something is not working please consult the HIARCS Chess Explorer FAQ page for the product:

In the event you are unable to resolve the issue you can email the HIARCS team

You may also wish to consult the HIARCS chess forum

Any updates issued for HIARCS Chess Explorer will be  available  from  www.hiarcs.com.  Information  about
any updates will be emailed to you and can be reached by using the Help->Check for updates menu option.
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